Bug 1121371 - Attempt to kickstart RHEL 7 in a KVM virtual machine ends with "gzip invoked oom-killer" and a stack trace
Summary: Attempt to kickstart RHEL 7 in a KVM virtual machine ends with "gzip invoked ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-20 03:29 UTC by Joe Thompson
Modified: 2015-10-06 02:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-21 21:35:41 UTC


Attachments (Terms of Use)

Description Joe Thompson 2014-07-20 03:29:49 UTC
Description of problem: Cannot install RHEL 7 in a VM with 786 MB of memory using kickstart from Satellite.  In a similar VM, RHEL 6.5 kickstarts fine.


Version-Release number of selected component (if applicable): 7.0


How reproducible: 100%


Steps to Reproduce:
1. Set up KVM VM with 768 GB of RAM.
2. Set up RHEL 7 kickstart on Satellite 5.6
3. Boot VM into kickstart

In my case, the kickstart specifies @Core and a handful of other packages and the VM has a 6-GB virtio disk, but that's probably not relevant to reproduce.

Actual results: Install aborts after "Reached target Initrd Default target." with a stack trace beginning "gzip invoked oom-killer".


Expected results: Install should complete normally.


Additional info: Bumping memory to 1 GB results in successful install and a system that runs with about 300 MB of memory used.  Using the DVD instead of kickstarting from Satellite also works.

Comment 2 Brian Lane 2014-07-21 21:32:27 UTC
When PXE booting you are going to need more RAM because the squashfs.img is stored in RAM, not mounted from an iso or nfs. You can also use text mode to save a bit.

Comment 3 RHEL Product and Program Management 2014-07-21 21:35:41 UTC
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.