Bug 1121431 - After a few seconds the display color profile is back to default
Summary: After a few seconds the display color profile is back to default
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: colord-kde
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Reznik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-20 21:57 UTC by Frédéric
Modified: 2014-07-21 14:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-21 14:18:13 UTC


Attachments (Terms of Use)

Description Frédéric 2014-07-20 21:57:10 UTC
Description of problem:
I have installed a color profile (called "P170HMx, precise matrix") for my display. This is what I see in KDE color settings:

Devices
+ Clevo - P170HMx
  + Default: P170HMx
  v P170HMx, precise matrix
the installed profiled is ticked and when I start a KDE session, this profile is applied but only for a few seconds and then the default profile is applied automatically. However, even if the default profile is automatically applied, the installed custom profile is still ticked in KDE color settings.

Version-Release number of selected component (if applicable):
colord-kde
Architecture        : x86_64
Version             : 0.3.0
Révision            : 2.fc20

How reproducible: always

Steps to Reproduce:
1. install a profile et select it so that it is applied
2. leave the KDE session
3. start a new KDE session

Actual results:
the custom profile is applied only for a few seconds


Expected results:
the custom profile is applied for the whole session.


Additional info:
have nvidia card + driver

Comment 1 Rex Dieter 2014-07-20 22:11:37 UTC
The "profile is applied only for a few seconds"... what happens to make you say that?

Comment 2 Frédéric 2014-07-20 22:14:23 UTC
I just removed the nvidia driver and the problem disappears. Seems related to the nvidia proprietary driver. I filed a bug:
https://devtalk.nvidia.com/default/topic/762690/linux/after-a-few-seconds-the-display-color-profile-is-back-to-default-fedora-20-kde4-/

Comment 3 Frédéric 2014-07-20 22:15:15 UTC
(In reply to Rex Dieter from comment #1)
> The "profile is applied only for a few seconds"... what happens to make you
> say that?

My wallpaper is a picture I took with my camera and I know very well when the profile is applied or not. The difference is huge.

Comment 4 Rex Dieter 2014-07-21 14:18:13 UTC
Thanks.

let's assume it's an nvidia issue (cantfix) until there's evidence to the contrary.


Note You need to log in before you can comment on or make changes to this bug.