Bug 1121433 - HPLIP fails to recognize reportlab
Summary: HPLIP fails to recognize reportlab
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-20 22:53 UTC by LarryO
Modified: 2014-07-26 00:09 UTC (History)
2 users (show)

Fixed In Version: hplip-3.14.6-5.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-26 00:09:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1328601 None None None Never

Description LarryO 2014-07-20 22:53:06 UTC
Description of problem:hplip doesn't recognize that reportlab 3.1.18 is installed because of the 2nd decimal version causing a ValueError exception to be thrown when it's converted to a float in function check_reportlab.


Version-Release number of selected component (if applicable):3.14.6-2.fc20.x86_64


How reproducible:100%


Steps to Reproduce:
1.Execute "hp-check"
2.
3.

Actual results:
 error: reportlab     Python-PDF-Lib            OPTIONAL        2.0             3.1.8           MISSING    'reportlab needs to be installed'

Expected results:
 error: reportlab     Python-PDF-Lib            OPTIONAL        2.0             3.1.8           OK

Additional info:
Prevents several HPLIP features including fax cover pages from functioning.

Comment 2 Fedora Update System 2014-07-21 16:58:14 UTC
hplip-3.14.6-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/hplip-3.14.6-5.fc20

Comment 3 LarryO 2014-07-21 22:45:23 UTC
The patch resovled the issue.

Thanks.

Comment 4 Fedora Update System 2014-07-22 03:34:03 UTC
Package hplip-3.14.6-5.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hplip-3.14.6-5.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8629/hplip-3.14.6-5.fc20
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-07-26 00:09:30 UTC
hplip-3.14.6-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.