Bug 11215 - Installer locks for dodgy partition table
Installer locks for dodgy partition table
Status: CLOSED DUPLICATE of bug 10518
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-04 09:29 EDT by neil
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-05 08:24:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description neil 2000-05-04 09:29:47 EDT
When installing RH6.2 in graphical mode the installer hangs if you have a
slightly dodgy partition table.

If the Partitions on the disk are not in the correct order, eg a partition
placed at cylinder 262-262 is listed after a partition placed at 263-264
the installer hangs due to the parition table being in the incorrect
logical order.

Fixed by resorting the partion table into the correct order,  Bit of an
issue for WIn32 users doing dual boot after using something like Partition
Magic.

The hang occurs as you press next in the 'select installation type' step.
Comment 1 Jay Turner 2000-05-05 07:41:59 EDT
Is this a matter of the partitions not being in the "correct" order, or rather
that there is a logical partition missing?  We have reports of people having
similar problems where Partition Magic has created a null partition (generally
hda5) thus the partition table looks like [hda1,hda2,(hda6)] when it should look
more like [hda1,hda2,(hda5)]

I will attempt to recreate this problem here in the lab.
Comment 2 Jay Turner 2000-05-05 08:20:59 EDT
In testing here at the lab I found that I was not able to replicate the problem
you are seeing just by messing with the partition table.  I tried misordering
primary as well as logical partitions and the installer handled it without any
problems.  As soon as I used Partition Magic to remove the hda5 logical
partition (and thus leaving a null partition) the installer would signal 11 on
install and upgrade, so I am betting this is what you are seeing.

I am trying to get in touch with the Partition Magic folks and see what the
workaround should be for this situation.
Comment 3 Jay Turner 2000-05-05 08:24:59 EDT
*** This bug has been marked as a duplicate of 10518 ***

Note You need to log in before you can comment on or make changes to this bug.