Bug 1121506 - VM channels listener crashes - RHEVM 3.4 UI doesn't show VM installed applications
Summary: VM channels listener crashes - RHEVM 3.4 UI doesn't show VM installed applica...
Keywords:
Status: CLOSED DUPLICATE of bug 1101021
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.4.0
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Nobody
QA Contact: meital avital
URL:
Whiteboard: virt
Depends On: 1102072
Blocks: 1101021 1114269
TreeView+ depends on / blocked
 
Reported: 2014-07-21 06:21 UTC by Roman Hodain
Modified: 2014-09-28 06:38 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1102072
Environment:
Last Closed: 2014-07-21 06:23:33 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 28179 None None None Never
oVirt gerrit 28297 None None None Never

Description Roman Hodain 2014-07-21 06:21:21 UTC
+++ This bug was initially created as a clone of Bug #1102072 +++

Description of problem:
RHEVM 3.4 admin UI doesn't show in tab VMs "Application" succesfully installed applications on that VM.
RHEVM - 3.4.0-0.20.el6ev

Host configuration:
Kernel Version: 2.6.32 - 431.5.1.el6.x86_64
KVM Version: 0.12.1.2 - 2.415.el6_5.6
LIBVIRT Version: libvirt-0.10.2-29.el6_5.5
VDSM Version: vdsm-4.14.2-0.4.el6ev

How reproducible:
100% reproducible

Steps to Reproduce:
1. Create VM (1024M, 4 CPU)
2. Connect to VM using SPICE
3. Install RHEL 6.5 from PXE
4. Update kernel 
# yum update kernel
Check version:
# rpm -q kernel
kernel-2.6.32-431.el6.x86_64
kernel-2.6.32-431.17.1.el6.x86_64
5. Update repo files
5.1. rhel65.repo   
[rhel-65]
name=RHEL_65
baseurl=<SNIP>
enabled=1
gpgcheck=0
 
[rhel-65-optional]
name=RHEL_65_OPTIONAL
baseurl=<SNIP>
enabled=1
gpgcheck=0
 
[rhel-65-zstream]
name=RHEL_65_Z
baseurl=<SNIP>
enabled=1
gpgcheck=0
rhel65.repo (END)

5.2. rhevm.repo
[qa-latest]
name=QA Latest build
baseurl=<SNIP>
enabled=1
gpgcheck=0
rhevm.repo (END)

[rhev-65-channel]
name=RHEV_65
baseurl=<SNIP>
enabled=1
gpgcheck=0

6. Install guest agent application
# yum install rhevm-guest-agent-common
Check version:
# rpm -q rhevm-guest-agent-common
rhevm-guest-agent-common-1.0.9-1.e16ev.noarch

7. Start guest agent 
# service ovirt-guest-agent start

8. Go to RHEVM admin portal
Select VM's tab "Application"

Actual results:
Nothing

Expected results:
kernel-2.6.32-431.el6.x86_64
kernel-2.6.32-431.17.1.el6.x86_64
rhevm-guest-agent-common-1.0.9-1.e16ev.noarch


Additional info:

--- Additional comment from Vinzenz Feenstra [evilissimo] on 2014-05-27 06:13:24 EDT ---

The problem is here:

Thread-623::INFO::2014-05-22 15:44:35,018::vm::4575::vm.Vm::(releaseVm) vmId=`1c9f6b74-86b5-4173-aa8e-3e294ea9f3f2`::Release VM resources
GuestMonitor-scale_165::DEBUG::2014-05-22 15:44:35,084::vm::684::vm.Vm::(_getDiskLatency) vmId=`41cae803-2be3-4030-bbd9-ac1d4164f89c`::Disk vda latency not available
GuestMonitor-scale_172::DEBUG::2014-05-22 15:44:35,091::vm::684::vm.Vm::(_getDiskLatency) vmId=`560196ff-da88-4689-975e-f4490a53b6ff`::Disk vda latency not available
GuestMonitor-scale_170::DEBUG::2014-05-22 15:44:35,169::vm::684::vm.Vm::(_getDiskLatency) vmId=`4f829ed7-546a-4557-a98a-f4583208e4cb`::Disk vda latency not available
Thread-623::DEBUG::2014-05-22 15:44:35,952::sampling::292::vm.Vm::(stop) vmId=`1c9f6b74-86b5-4173-aa8e-3e294ea9f3f2`::Stop statistics collection
Thread-623::DEBUG::2014-05-22 15:44:35,998::vmChannels::205::vds::(unregister) Delete fileno 136 from listener.
Thread-335::DEBUG::2014-05-22 15:44:36,007::sampling::323::vm.Vm::(run) vmId=`1c9f6b74-86b5-4173-aa8e-3e294ea9f3f2`::Stats thread finished
GuestMonitor-scale_36::DEBUG::2014-05-22 15:44:36,064::vm::645::vm.Vm::(_getDiskStats) vmId=`32d4c23f-2719-47f4-9ad7-45977e98a1a5`::Disk hdc stats not available
GuestMonitor-scale_36::DEBUG::2014-05-22 15:44:36,073::vm::645::vm.Vm::(_getDiskStats) vmId=`32d4c23f-2719-47f4-9ad7-45977e98a1a5`::Disk vda stats not available
GuestMonitor-scale_36::DEBUG::2014-05-22 15:44:36,081::vm::684::vm.Vm::(_getDiskLatency) vmId=`32d4c23f-2719-47f4-9ad7-45977e98a1a5`::Disk hdc latency not available
GuestMonitor-scale_36::DEBUG::2014-05-22 15:44:36,088::vm::684::vm.Vm::(_getDiskLatency) vmId=`32d4c23f-2719-47f4-9ad7-45977e98a1a5`::Disk vda latency not available
VM Channels Listener::DEBUG::2014-05-22 15:44:36,129::vmChannels::112::vds::(_do_del_channels) fileno 136 was removed from listener.
VM Channels Listener::ERROR::2014-05-22 15:44:36,584::vmChannels::176::vds::(run) Unhandled exception caught in vm channels listener thread
Traceback (most recent call last):
  File "/usr/share/vdsm/vmChannels.py", line 174, in run
  File "/usr/share/vdsm/vmChannels.py", line 161, in _wait_for_events
  File "/usr/share/vdsm/vmChannels.py", line 60, in _handle_event
KeyError: 136
VM Channels Listener::INFO::2014-05-22 15:44:36,603::vmChannels::178::vds::(run) VM channels listener thread has ended.

This caused the listener loop to stop.

--- Additional comment from Vinzenz Feenstra [evilissimo] on 2014-06-03 02:40:45 EDT ---

Merged to u/s master as http://gerrit.ovirt.org/gitweb?p=vdsm.git;a=commit;h=7143dd21665bf866c784c765570375abd70954b4

Comment 1 Roman Hodain 2014-07-21 06:23:33 UTC

*** This bug has been marked as a duplicate of bug 1101021 ***


Note You need to log in before you can comment on or make changes to this bug.