Bug 112153 - Server refuses to start with Listen 127.0.0.1:80
Server refuses to start with Listen 127.0.0.1:80
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: apache (Show other bugs)
2.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-15 09:22 EST by Nick Strugnell
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-06 11:16:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Strugnell 2003-12-15 09:22:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
When configuring a server to only listen to port 80 on the loopback
interface using 'Listen 127.0.0.1:80' this causes the following error
at startup:

(98)Address already in use: make_sock: could not bind to address
127.0.0.1 port 80

Version-Release number of selected component (if applicable):
1.3.27-6.ent

How reproducible:
Always

Steps to Reproduce:
1.Edit httpd.conf and add the Listen line shown above
2. Start server
3.
    

Actual Results:  Server fails to start - error appears in syslog

Expected Results:  Server start

Additional info:

This is caused by the repeat Listen directive at line 397. Comment
this out and things should be fine.

The problem is really one of the way the httpd.conf file is commented
- the commented listen directives at line 175 give no indication that
there is an uncommented directive at 397.
Comment 1 Joe Orton 2004-02-06 11:16:49 EST
It's a good point, but changing the default httpd.conf in an erratum
is somewhat annoying since the new file would be created as
httpd.conf.rpmnew for anyone who updated.  Certainly just to fix a
comment, it's not worth it... so I'll just mark this
CLOSED->CURRENTRELEASE since the httpd.conf shipping in RHEL3 doesn't
have this issue.

Note You need to log in before you can comment on or make changes to this bug.