Bug 1121552 - Can not release email from SQL quarantine with new stable version 2.9.1
Summary: Can not release email from SQL quarantine with new stable version 2.9.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: amavisd-new
Version: el6
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Juan Orti Alcaine
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 08:13 UTC by g.danti
Modified: 2014-08-22 19:16 UTC (History)
6 users (show)

Fixed In Version: amavisd-new-2.9.1-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-22 19:16:29 UTC


Attachments (Terms of Use)

Description g.danti 2014-07-21 08:13:51 UTC
Description of problem:
With the new amavisd-new stable version (2.9.1) it is not possibile to release emails from SQL quarantine using the amavisd-release program. When trying to do that, amavis complain about a non-existent mail_id. Analyzing the log file it appear that the mail_id is correctly passed by amavisd-release but then the amavisd perl daemon overwrite the correct value with random data.

Version-Release number of selected component (if applicable):
2.9.1, 2.9.0

How reproducible:
When using an SQL quarantine: always
On other quarantine types: I don't know (I use SQL quarantine exclusively)

Steps to Reproduce:
1. set up and SQL quarantine
2. let a spam email enter the SQL quarantine
3. try to release the blocked email via the amavisd-release program (eg: /usr/bin/amavisd-release 0-vFmNRKpWLO5K)

Actual results:
450 4.5.0 Failure: Can't open sql obj for reading: No such file or directory at (eval 109) line 375, <GEN21> line 4.

Expected results:
The email shoud be released and queued for delivery

Additional info:
[1] http://lists.amavis.org/pipermail/amavis-users/2014-July/003039.html
[2] http://lists.amavis.org/pipermail/amavis-users/2014-June/002957.html

Workarounds:
1. Change line 20177 in /usr/sbin/amavisd as below:
$msginfo->mail_id($mail_id);

2. Apply a slight more extensive path as by link n.2 above

3. Revert to amavisd-new ver. 2.8.1

Comment 1 Juan Orti Alcaine 2014-08-03 21:22:55 UTC
Sorry for introducing this bug. I'm going to submit an update with the patch of the second link.

I don't have any sql deployment to test it, so I'll need your feedback on the update.

Comment 2 Fedora Update System 2014-08-03 21:23:59 UTC
amavisd-new-2.9.1-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/amavisd-new-2.9.1-2.el6

Comment 3 g.danti 2014-08-04 13:58:56 UTC
Hi all,
I can confirm that, with the new amavisd-new-2.9.1-2.el6, the problem is fixed.

Running amavisd-release I see:
[root@spambox ~]# amavisd-release 0-rQEL05XC_c-7
250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as A9BD2404

So the packet seems to work correctly. I'm waiting to see it into EPEL stable repository :)
Thanks.

Comment 4 Fedora Update System 2014-08-07 11:49:03 UTC
Package amavisd-new-2.9.1-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing amavisd-new-2.9.1-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2137/amavisd-new-2.9.1-2.el6
then log in and leave karma (feedback).

Comment 5 g.danti 2014-08-11 09:15:54 UTC
Hi all,
I tried the new epel-testing package on two different servers and I confirm that it works. So the bug seems solved.

I'm waiting to see the new package pushed to stable repository. Thanks.

Comment 6 Fedora Update System 2014-08-22 19:16:29 UTC
amavisd-new-2.9.1-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.