Bug 1121562 - /etc/profile.d/firstboot.sh does not expect zsh or ksh
Summary: /etc/profile.d/firstboot.sh does not expect zsh or ksh
Keywords:
Status: CLOSED DUPLICATE of bug 1117749
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: firstboot
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Martin Kolman
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 08:39 UTC by Petr Sklenar ⛄
Modified: 2014-10-09 12:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-09 12:56:03 UTC


Attachments (Terms of Use)

Description Petr Sklenar ⛄ 2014-07-21 08:39:03 UTC
Description of problem:
/etc/profile.d/firstboot.sh does not expect zsh

Version-Release number of selected component (if applicable):
firstboot-1.110.15-1.el6.s390x

How reproducible:
always

Steps to Reproduce:
1. change shell to zsh
2. start new session:
/etc/profile.d/firstboot.sh:10: bad substitution
[me@ibm-z10-32]~% echo $SHELL
/bin/zsh
[me@ibm-z10-32]~% /bin/zsh /etc/profile.d/firstboot.sh
/etc/profile.d/firstboot.sh:10: bad substitution
[me@ibm-z10-32]~% /bin/bash /etc/profile.d/firstboot.sh 
[me@ibm-z10-32]~% 

Actual results:
error when zsh is your default shell

Expected results:
no error when default shell is zsh or different then bash

Additional info:

Comment 2 Petr Sklenar ⛄ 2014-07-21 08:44:07 UTC
similar issue for korn shell:
[root@ibm-z10-32 bz923655-cannot-find-twm-in-any-package]# su - me
/etc/profile[70]: .: line 124: syntax error: `,' unexpected
$ echo $SHELL
/bin/ksh

Comment 3 David Cantrell 2014-10-09 12:56:03 UTC

*** This bug has been marked as a duplicate of bug 1117749 ***


Note You need to log in before you can comment on or make changes to this bug.