Bug 1121570 - dnf update --best fails with Error: bad problem rule type
Summary: dnf update --best fails with Error: bad problem rule type
Keywords:
Status: CLOSED DUPLICATE of bug 1099342
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Honza Silhan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 09:03 UTC by Hans de Goede
Modified: 2014-07-30 12:47 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-30 12:47:53 UTC


Attachments (Terms of Use)
dnf update --debugsolver --best debugdata output (7.49 MB, application/octet-stream)
2014-07-22 06:25 UTC, Hans de Goede
no flags Details

Description Hans de Goede 2014-07-21 09:03:25 UTC
When running dnf update --best (or set best=true in dnf.conf) I get the following on a fully up2date F-21:

[hans@shalem ~]$ sudo dnf update --best -v
cachedir: /var/cache/dnf/x86_64/21
DNF version: 0.5.4
repo: using cache for: updates-testing
repo: using cache for: fedora
not found deltainfo for: Fedora 21 - x86_64
repo: using cache for: whot-libinput-userstudy
not found deltainfo for: Copr repo for libinput-userstudy owned by whot
repo: using cache for: rpmfusion-free-rawhide
not found deltainfo for: RPM Fusion for Fedora Rawhide - Free
repo: using cache for: adobe-linux-x86_64
not found deltainfo for: Adobe Systems Incorporated
repo: using cache for: adobe-linux-i386
not found deltainfo for: Adobe Systems Incorporated
repo: using cache for: rpmfusion-nonfree-rawhide
not found deltainfo for: RPM Fusion for Fedora Rawhide - Nonfree
repo: using cache for: updates
--> Starting dependency resolution
--> Finished dependency resolution
Error: bad problem rule type. bad problem rule type. bad problem rule type. bad problem rule type

Let me know what I can do to collect more debug-info for you.

Comment 1 Honza Silhan 2014-07-21 17:12:50 UTC
Hi, thanks for the report. I can't see any error reproducing in f21 docker image. The message is unknown error from libsolv. Can you attach debugdata (http://dnf.baseurl.org/2013/11/25/reporting-depsolving-bugs/), please?

Comment 2 Hans de Goede 2014-07-22 06:25:24 UTC
Created attachment 919805 [details]
dnf update  --debugsolver --best debugdata output

Comment 3 Michael Schröder 2014-07-30 09:53:18 UTC
The bad error message is already fixed in current libsolv (the one that includes the "yum obsoletes" code).

The error itself comes from conflicting jobs: the "update --best" conflicts with  the locks for the openssl* packages. If you switch over to the pool->considered
mechanism for package excludes, the error will also be gone.

Comment 4 Hans de Goede 2014-07-30 11:01:29 UTC
(In reply to Michael Schröder from comment #3)
> The bad error message is already fixed in current libsolv (the one that
> includes the "yum obsoletes" code).
> 
> The error itself comes from conflicting jobs: the "update --best" conflicts
> with  the locks for the openssl* packages.

Ah yes, that makes sense.

> If you switch over to the pool->considered
> mechanism for package excludes, the error will also be gone.

I guess that is something which needs to be changed in the dnf code, or is it a config / repo setting ?

Comment 5 Michael Schröder 2014-07-30 11:08:31 UTC
Yes, it'll be a change in dnf & hawkey. See bug #1099342.

Comment 6 Honza Silhan 2014-07-30 12:47:53 UTC
Thanks for the libsolv fix and info, Michael.

*** This bug has been marked as a duplicate of bug 1099342 ***


Note You need to log in before you can comment on or make changes to this bug.