Bug 1121578 - [RFE] Implement an installer precheck for attached subscriptions
Summary: [RFE] Implement an installer precheck for attached subscriptions
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 09:27 UTC by Lukas Zapletal
Modified: 2017-08-24 20:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-24 20:26:10 UTC


Attachments (Terms of Use)

Description Lukas Zapletal 2014-07-21 09:27:09 UTC
Instad of puppet errors when dependencies cannot be installed, let's write a simple shell script that verifies the following and add it as a hook:

- RHEL6 repo is present
- optional ditto
- RHSCL ditto

If anything is not met, we should print out nice error with instructions how to fix it.

Proposing for GA, easy to implement.

Comment 1 RHEL Product and Program Management 2014-07-21 09:43:41 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Bryan Kearney 2014-07-21 11:57:55 UTC
Need to ensure the check can handle the ISO install scenario

Comment 4 Dominic Cleal 2014-07-24 13:56:20 UTC
Also users are free to use non-official repos (i.e. clones), so an override should be provided.

Comment 6 Bryan Kearney 2017-08-24 20:26:10 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.