Bug 1121605 - [RFE] katello-installer should provide additional options to enable easier integration with existing DNS servers.
Summary: [RFE] katello-installer should provide additional options to enable easier in...
Keywords:
Status: CLOSED DUPLICATE of bug 1121559
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 10:59 UTC by Rich Jerrido
Modified: 2014-07-21 11:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-21 11:25:05 UTC


Attachments (Terms of Use)

Description Rich Jerrido 2014-07-21 10:59:19 UTC
Description of problem:

When deploying Satellite in environments with existing DNS infrastructure, the user wishes to easily configure Satellite to be able to add/remove DNS entries on their DNS servers. 

Example usage:

The user has a server, dnsbox.example.com, which hosts two DNS zones, example.com &
hosts.example.com. Both are dynamic zones which have the appropriate
RNDC keys setup.

A Satellite, which the user is planning to deploy as satellite.hosts.example.com, which will provision additional hosts in
the hosts.example.com domain.

The user doesn't wish to run a DNS server locally on the Satellite, as there is existing infrastructure that provides DNS. 


Currently the user is required to manually configure /etc/foreman-proxy/settings.yml to achieve this configuration.  This should be optimally exposed via the installer, so that the end-user can have a working configuration 'out of box'


Version-Release number of selected component (if applicable):
katello-installer-0.0.53-1.el6sat.noarch


Additional info:

As a point of comparison, upstream Foreman supports the following install options:

    --foreman-proxy-dns-managed   DNS is managed by Foreman proxy (default: true)
    --foreman-proxy-dns-server    Address of DNS server to manage (default: "127.0.0.1")


This RFE requests similar functionality added to katello-installer.

Comment 1 RHEL Product and Program Management 2014-07-21 11:13:49 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Ivan Necas 2014-07-21 11:25:05 UTC

*** This bug has been marked as a duplicate of bug 1121559 ***


Note You need to log in before you can comment on or make changes to this bug.