Bug 1121608 - [spicec] (RHEL5) Error connecting to Virtual Machine using SPICE: Internal error (code 1032)
Summary: [spicec] (RHEL5) Error connecting to Virtual Machine using SPICE: Internal er...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: spice-client
Version: 5.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Uri Lublin
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 11:12 UTC by Jiri Belka
Modified: 2015-08-24 12:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-24 12:17:25 UTC


Attachments (Terms of Use)
various logs (3.38 KB, application/x-gzip)
2014-07-21 11:12 UTC, Jiri Belka
no flags Details

Description Jiri Belka 2014-07-21 11:12:22 UTC
Created attachment 919607 [details]
various logs

Description of problem:
I can't open SPICE console using RHEL5 client with RHEVM 3.4 (av10.3). The problem is:

1405932599 ERROR [2841:2841] main: unhandled exception: invalid action bname secure-attention

It seems spicec doesn't know about new "features" - secure-attention=ctrl+alt+del (which is visible in .vv file).

Well RHEL5 doesn't have newer virt-viewer which would contain remote-viewer thus only possible workaround is to unselect (disable) 'Map control-alt-del shortcut ot ctrl+alt+end' in RHEVM console options.

Version-Release number of selected component (if applicable):
spice-client-0.8.1-8.el5
virt-viewer-0.0.2-3.el5

How reproducible:
100%

Steps to Reproduce:
1. open spice console from RHEL5 client while having 'Map control-alt-del shortcut to ctrl+alt+del' enabled (which is default)
2.
3.

Actual results:
doesn't work

Expected results:
should work

Additional info:

Comment 2 Marc-Andre Lureau 2014-07-21 12:36:39 UTC
Why is this bug opened to RHEL6? I suppose it is reproducible with rhel5 and rhel6, then we should open a duplicate.

Comment 3 Marc-Andre Lureau 2014-07-21 12:49:11 UTC
This should fix the issue (necessary on rhel5 only)

commit 67178944d26a97a6fb73ddf92b7fefdec6a99fd9
Author: Christophe Fergeau <cfergeau@redhat.com>
Date:   Fri Feb 3 13:11:11 2012 +0100

    Handle Application::set_hotkeys failure
    
    Application::set_hotkeys can throw an exception if it fails parsing
    the string describing the hotkeys to set. Currently this exception
    is uncaught which causes spicec to terminate when the controller
    tries to set invalid hotkeys. Fall back to using the default
    hotkeys when the controller sends an invalid hotkeys string.

Comment 4 David Blechter 2015-08-24 12:17:25 UTC
Spice in rhel 5.x is not supported


Note You need to log in before you can comment on or make changes to this bug.