Bug 1121618 - debhelper-9.20140228-1.fc22 FTBFS: race in tests?
Summary: debhelper-9.20140228-1.fc22 FTBFS: race in tests?
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: debhelper
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Oron Peled
QA Contact: Fedora Extras Quality Assurance
URL: http://koji.fedoraproject.org/koji/ta...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 11:57 UTC by Petr Pisar
Modified: 2014-07-31 14:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-31 14:42:44 UTC


Attachments (Terms of Use)

Description Petr Pisar 2014-07-21 11:57:19 UTC
debhelper-9.20140228-1.fc22 failed to build for me because of tests:

#   Failed test 'DEB_BUILD_OPTIONS=parallel=5 with --parallel'
#   at t/buildsystems/buildsystem_tests line 561.
#     Structures begin differing at:
#          $got->[0] = 'make[1]: *** [FIRST] Error 10'
#     $expected->[0] = Does not exist
#   Failed test '(exit status=0) DEB_BUILD_OPTIONS=parallel=5 with --parallel'
#   at t/buildsystems/buildsystem_tests line 562.
#          got: '2'
#     expected: '0'
# Looks like you failed 2 tests of 297.
t/buildsystems/buildsystem_tests .. 
Dubious, test returned 2 (wstat 512, 0x200)
Failed

Anothewr scratch build in koji <http://koji.fedoraproject.org/koji/taskinfo?taskID=7171555> failed with:

#   Failed test 'autoconf/stamp_configure contains extra args'
#   at t/buildsystems/buildsystem_tests line 472.
#     Structures begin differing at:
#          $got->[0] = '--host=arm-linux-gnueabi'
#     $expected->[0] = Does not exist
#   Failed test 'autoconf/stamp_test exists'
#   at t/buildsystems/buildsystem_tests line 477.
#   Failed test 'bld/dir/stamp_configure contains extra args'
#   at t/buildsystems/buildsystem_tests line 472.
#     Structures begin differing at:
#          $got->[0] = '--host=arm-linux-gnueabi'
#     $expected->[0] = '--extra-autoconf-configure-arg'
#   Failed test 'bld/dir/stamp_test exists'
#   at t/buildsystems/buildsystem_tests line 477.
# Looks like you failed 4 tests of 297.
t/buildsystems/buildsystem_tests .. 
Dubious, test returned 4 (wstat 1024, 0x400)
Failed 4/297 subtests 
Test Summary Report
-------------------
t/buildsystems/buildsystem_tests (Wstat: 1024 Tests: 297 Failed: 4)
  Failed tests:  248, 252, 262, 266
  Non-zero exit status: 4
Files=8, Tests=588, 24 wallclock secs ( 0.39 usr  0.04 sys + 15.35 cusr  3.15 csys = 18.93 CPU)
Result: FAIL

Similar issue has already been reported as bug #1106129.

This looks like a race in the tests.

Comment 1 Sergio Monteiro Basto 2014-07-21 20:18:58 UTC
I report this to devel ML 

https://lists.fedoraproject.org/pipermail/devel/2014-February/195730.html

but was not conclusive , maybe upstream (debhelper) the problem ?

Comment 2 Petr Pisar 2014-07-22 05:49:39 UTC
Just for your information, the first failure is from local mock on x86_64. Try ask upstream how to debug it.

Comment 3 Sergio Monteiro Basto 2014-07-23 20:00:16 UTC
(In reply to Petr Pisar from comment #2)
> Just for your information, the first failure is from local mock on x86_64.
> Try ask upstream how to debug it.

sorry I'm in holidays, the bug you mention, the problem was when builder is one arm , not happened when build was not a arm .
So if you got tests fails on builder that is not an arm we got another bug .
on my local mock I can't reproduce the problem because my laptop is an x86_64. 
your first fail test is not about --host=arm-linux-gnueabi , I will checkout when I'm back

Comment 4 Sergio Monteiro Basto 2014-07-27 20:43:03 UTC
(In reply to Petr Pisar from comment #2)
> Just for your information, the first failure is from local mock on x86_64.
> Try ask upstream how to debug it.

Hi, today local mock on x86_64 builds well for rawhide, although I had a fail some days ago , but not now so I assume this problem is solved. 

Can you check it and close the bug if it is fixed ? 

Thanks,

Comment 5 Petr Pisar 2014-07-28 08:58:02 UTC
The only change in code is:

diff -Naur debhelper-9.20140228/Debian/Debhelper/Buildsystem/autoconf.pm debhelper/Debian/Debhelper/Buildsystem/autoconf.pm
--- debhelper-9.20140228/Debian/Debhelper/Buildsystem/autoconf.pm       2013-09-03 20:44:37.000000000 +0200
+++ debhelper/Debian/Debhelper/Buildsystem/autoconf.pm  2014-06-13 17:49:04.000000000 +0200
@@ -37,6 +37,9 @@
        push @opts, "--infodir=\${prefix}/share/info";
        push @opts, "--sysconfdir=/etc";
        push @opts, "--localstatedir=/var";
+       if (defined $ENV{DH_VERBOSE} && $ENV{DH_VERBOSE} ne "") {
+               push @opts, "--disable-silent-rules";
+       }
        my $multiarch=dpkg_architecture_value("DEB_HOST_MULTIARCH");
        if (! compat(8)) {
               if (defined $multiarch) {
diff -Naur debhelper-9.20140228/dh_installinit debhelper/dh_installinit
--- debhelper-9.20140228/dh_installinit 2013-11-10 20:23:13.000000000 +0100
+++ debhelper/dh_installinit    2014-05-24 19:33:24.000000000 +0200
@@ -165,7 +165,7 @@
        my $scriptsrc;
        my $jobfile=$package;
        if (defined $dh{NAME}) {
-               $jobfile=$script=$dh{NAME};
+               $jobfile=$script=$scriptsrc=$dh{NAME};
        }
        elsif ($dh{D_FLAG}) {
                # -d on the command line sets D_FLAG. We will 

I don't believe this could fix the race.

It's not possible to prove the bug is fixed just by passing build. You can only prove by this method that the bug is still there.

Comment 6 Sergio Monteiro Basto 2014-07-28 16:50:03 UTC
(In reply to Petr Pisar from comment #5)
> It's not possible to prove the bug is fixed just by passing build. You can
> only prove by this method that the bug is still there.


I said the bug was fixed, before update debhelper, the fix was not the debhelper update , but rawhide updates ... 

have you ever got this bug in F21 branch ?

Comment 7 Petr Pisar 2014-07-29 06:31:23 UTC
(In reply to Sergio Monteiro Basto from comment #6)
> (In reply to Petr Pisar from comment #5)
> > It's not possible to prove the bug is fixed just by passing build. You can
> > only prove by this method that the bug is still there.
> 
> 
> I said the bug was fixed, before update debhelper, the fix was not the
> debhelper update , but rawhide updates ... 
> 
That could be possible.

> have you ever got this bug in F21 branch ?
No.

Comment 8 Sergio Monteiro Basto 2014-07-31 14:42:44 UTC
OK , I'm closing this bug, as not a bug in debhelper ,  if problem persist please reopen it .

Best regards


Note You need to log in before you can comment on or make changes to this bug.