Bug 1121624 - ghc-hint fails to build on s390* and ppc* since it needs ghci
Summary: ghc-hint fails to build on s390* and ppc* since it needs ghci
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ghc-hint
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ZedoraTracker
TreeView+ depends on / blocked
 
Reported: 2014-07-21 12:05 UTC by Jakub Čajka
Modified: 2014-07-30 21:57 UTC (History)
1 user (show)

Fixed In Version: ghc-ghc-mtl-1.2.1.0-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-30 21:57:38 UTC


Attachments (Terms of Use)
Koji shadow build log (4.84 KB, text/x-log)
2014-07-21 12:05 UTC, Jakub Čajka
no flags Details

Description Jakub Čajka 2014-07-21 12:05:53 UTC
Created attachment 919615 [details]
Koji shadow build log

Description of problem:
ghc-hint fails to build on s390(x)

Shadow build( http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=1441416 ) fails with:
Building hint-0.4.2.0...
Preprocessing library hint-0.4.2.0...
[ 1 of 23] Compiling Hint.SignalHandlers ( src/Hint/SignalHandlers.hs, dist/build/Hint/SignalHandlers.o )
[ 2 of 23] Compiling Hint.Util        ( src/Hint/Util.hs, dist/build/Hint/Util.o )
[ 3 of 23] Compiling Hint.CompatPlatform ( src/Hint/CompatPlatform.hs, dist/build/Hint/CompatPlatform.o )
[ 4 of 23] Compiling Hint.GHC         ( src/Hint/GHC.hs, dist/build/Hint/GHC.o )
[ 5 of 23] Compiling Hint.Compat      ( src/Hint/Compat.hs, dist/build/Hint/Compat.o )
src/Hint/Compat.hs:53:6: Not in scope: `GHC.setContext'
src/Hint/Compat.hs:56:14: Not in scope: `GHC.getContext'
src/Hint/Compat.hs:145:53:
    Not in scope: type constructor or class `GHC.HValue'
src/Hint/Compat.hs:146:27: Not in scope: `GHC.compileExpr'
src/Hint/Compat.hs:150:24: Not in scope: `GHC.exprType'
src/Hint/Compat.hs:158:39: Not in scope: `GHC.typeKind'

Comment 3 Jens Petersen 2014-07-22 04:07:52 UTC
This issue is not s390* specific it also applies to ppc*.

The problem is that hint needs ghci support to build.
So I will do an update that excludes archs without ghci support.

Comment 4 Fedora Update System 2014-07-22 05:47:58 UTC
ghc-ghc-mtl-1.2.1.0-1.fc20, ghc-hint-0.4.2.0-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2014-8435/ghc-ghc-mtl-1.2.1.0-1.fc20,ghc-hint-0.4.2.0-2.fc20

Comment 5 Fedora Update System 2014-07-23 02:59:57 UTC
ghc-ghc-mtl-1.2.1.0-1.fc20, ghc-hint-0.4.2.0-2.fc20 has been pushed to the Fedora 20 testing repository.

Comment 6 Fedora Update System 2014-07-30 21:57:38 UTC
ghc-ghc-mtl-1.2.1.0-1.fc20, ghc-hint-0.4.2.0-2.fc20 has been pushed to the Fedora 20 stable repository.


Note You need to log in before you can comment on or make changes to this bug.