Bug 1121631 - [Nagios] - When a host/brick/volume is added graphs does not show correct values for Last,Average and Max
Summary: [Nagios] - When a host/brick/volume is added graphs does not show correct val...
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nagios-server-addons
Version: rhgs-3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Sahina Bose
QA Contact: RHS-C QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 12:17 UTC by RamaKasturi
Modified: 2018-01-30 07:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-30 07:55:14 UTC


Attachments (Terms of Use)
Volume Utilization Graph (148.05 KB, image/png)
2014-07-21 12:17 UTC, RamaKasturi
no flags Details

Description RamaKasturi 2014-07-21 12:17:05 UTC
Created attachment 919619 [details]
Volume Utilization Graph

Description of problem:
When a host/brick/volume is added the following gets displayed at the bottom of every graph until the reschedule happens.
-nan% Last -nan% Average -nan% Max

Version-Release number of selected component (if applicable):
nagios-server-addons-0.1.5-1.el6rhs.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Install nagios on rhs nodes.
2. Create a cluster and add volumes to it.
3. Now click on the volume, brick, cpu, memory,disk and swap utilization.

Actual results:
On the bottom of every graph it displays -nan% Last -nan% Average -nan% Max, till the next reschedule happens.

Expected results:
on the graphs it should not display -nan% Last -nan% Average -nan% Max

Additional info:

Comment 2 RamaKasturi 2014-09-16 05:51:29 UTC
Similar issue is seen with snapshot restore.

When snapshot is restored, brick utilization graph displays max, last and average as -nan% until the next reschedule happens.

Comment 3 Shruti Sampat 2014-09-16 11:22:47 UTC
Similar issue seen with network utilization graphs too. When a node is just configured for monitoring with nagios, graphs for network utilization service are affected by this issue.

Comment 4 Timothy Asir 2014-09-17 09:00:33 UTC
Looks like this is a RRD sync-up issue. We will look into further and update here. Meanwhile could you please attach the plugin xml data file before and after adding host or brick or volume.

Comment 7 Sahina Bose 2018-01-30 07:55:14 UTC
Thank you for the bug report. However, closing this as the bug is filed against gluster nagios monitoring for which no further new development is being undertaken.


Note You need to log in before you can comment on or make changes to this bug.