Bug 1121647 - [Doc Bug Fix] Incorrect commands for Microsoft Windows Server + amendment for 1089391
Summary: [Doc Bug Fix] Incorrect commands for Microsoft Windows Server + amendment for...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation
Version: 6.3.0
Hardware: All
OS: Windows
unspecified
high
Target Milestone: post-GA
: EAP 6.4.2
Assignee: David Michael
QA Contact: Michal Karm Babacek
URL:
Whiteboard:
: 1089391 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 13:24 UTC by Michal Karm Babacek
Modified: 2015-10-20 04:39 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Build Name: 22508, Administration and Configuration Guide-6.3-1 Build Date: 17-07-2014 23:26:30 Topic ID: 5728-685733 [Specified]
Last Closed: 2015-10-20 04:39:12 UTC
Type: Bug
dmichael: needinfo-


Attachments (Terms of Use)

Description Michal Karm Babacek 2014-07-21 13:24:43 UTC
Dear doc guys, there are several issues with Apache HTTP Server on Microsoft Windows Server I would like to address. ({code} detonates command input, {quote} stands for the actual text for the documentation)
 
1) Please, replace occurrences of the following:
 
{code}
C:\> net stop Apache2.2
C:\> net start Apache2.2
{code}
 
with
 
{code}
net stop Apache2.2
net start Apache2.2
{code}


2) Replace occurrences of the following:
 
{code}
C:\> net service http
C:\> net service httpd start
{code}

with

{code}
net stop Apache2.2
net start Apache2.2
{code}

3) Enhance the note:

Chapter 19.3.2. Install the Apache HTTP Server included with JBoss EAP 6 (Zip):
   "Note: For information on Apache HTTP Server installation for Microsoft Windows Server environment..."
 
I would like to add more info to the aforementioned note box (or make it a sub-Chapter perhaps...?), something along these lines:

{quote}
One can install the Apache HTTP Server service with this command:

{code}
cd /D "%EWS_HOME%\bin"
httpd -k install
{code}

The aforementioned command installs Apache HTTP Server service named Apache2.2.
One can specify a different name for the service, e.g. ApacheBalancer, with the following installation command:

{code}
cd /D "%EWS_HOME%\bin"
httpd -k install -n ApacheBalancer
{code}

If one wants to uninstall the service, it must be referenced by name. In this example, the command is as follows:

{code}
cd /D "%EWS_HOME%\bin"
httpd -k uninstall -n ApacheBalancer
{code}

The service can be started in two ways. One can either leverage the httpd.exe as:

{code}
cd /D "%EWS_HOME%\bin"
httpd -k start -n Apache2.2
{code}

or take advantage of the service manager:

{code}
net start Apache2.2
{code}

Apache2.2 and ApacheBalancer are arbitrary Apache HTTP Server service names with Apache2.2 being the default name. Stopping the service is analogical to the aforementioned examples with "stop" being used instead of "start".

{quote}


PS: Guys, if you find a way how to avoid repeating that 
    cd /D "%EWS_HOME%\bin"
please, do so. Perhaps, we may say that all these commands are to be executed in that directory?
Furthermore, note there that one must be an Administrator to carry out these tasks.

Thank you :-)

Comment 1 Michal Karm Babacek 2014-07-21 13:27:00 UTC
*** Bug 1089391 has been marked as a duplicate of this bug. ***

Comment 2 Michal Karm Babacek 2014-11-06 13:43:07 UTC
Dear Doc guys, could you look into it please?

Comment 3 Michal Karm Babacek 2015-01-20 14:00:58 UTC
Hi Tom, I would like to highlight my previous comment 1 and kindly ask you whether you could have a look at the status of this bugzilla and update it within the context of the latest EAP 6.4 documentation build.

Thank you

Comment 8 Radim Hatlapatka 2015-06-19 12:31:33 UTC
Revision: 6.4.0-30 
Book: Administration and Configuration guide
Section: 17.4.3. Install Apache HTTP Server Service for Microsoft Windows Server
Environment

It looks almost OK, I have found just three issues:

First issue:

Issue description:
In description for "2. To start a service, you can either use httpd.exe or service manager." there is typo:
You claim both cases are done using httpd.exe even though second time it is done using service manager

Suggestion for improvement:
In second case change "Using httpd.exe" to "Usinge service manager:"


Second issue:

Issue description:
Missing description how to stop the Apache service

Suggestion for improvement:
Add commands for stopping the service similarly as it is done for start commands or at least add note that it is analogical to the start commands  just using 'stop' instead of 'start' in those commands.


Third issue (note):
Issue description:
The title of this section is named "*Install* Apache HTTP Server Service ....." and there is not described only installation but uninstallation, starting and stopping.

Suggestion for improvement:
Change title name to be more representative that there isn't described only installation of the service.

Comment 11 Radim Hatlapatka 2015-07-13 12:43:46 UTC
Verified with EAP docs revision 6.4.0-32


Note You need to log in before you can comment on or make changes to this bug.