Bug 112165 - kickstart module can't handle multiple swap partitions
kickstart module can't handle multiple swap partitions
Status: CLOSED DUPLICATE of bug 115029
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fanny Augustin
:
Depends On:
Blocks: 111817
  Show dependency treegraph
 
Reported: 2003-12-15 11:38 EST by Lans Carstensen
Modified: 2007-08-06 14:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lans Carstensen 2003-12-15 11:38:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030709

Description of problem:
It's perfectly legal to have multiple swap partitions, we actually
require it.  Here's the automatic mail report from the Kickstart
provisioning module:

The following exception occured while executing this request:
 POST /network/systems/provisioning/kickstarts/select_options.pxt
HTTP/1.1 (from browser)
 /network/systems/provisioning/kickstarts/select_options.pxt (from Apache)

Date:
  Mon Dec 15 08:28:47 2003

Headers:
  Accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1
  Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  Accept-Encoding: gzip,deflate
  Accept-Language: en-us,en;q=0.5
  Connection: keep-alive
  Content-Length: 810
  Content-Type: application/x-www-form-urlencoded
  Cookie: pxt-session-cookie=19x71fa53d99377dc5eb8e528152a157b96
  Host: humphries.anim.dreamworks.com
  Keep-Alive: 300
  Referer:
https://humphries.anim.dreamworks.com/network/systems/provisioning/kickstarts/select_options.pxt?ksid=1
  User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4)
Gecko/20030709

Form variables:
  Update Kickstart => Update Kickstart
  active => Y
  bootloader => grub
  dhcp_ip_iface => eth0
  formvar_hmac => df3acfca7aa703e8b0a430abfcfce3b8087ef5e6
  ks_ip_type => dhcp
  ksid => 1
  label => lhctest
  name => lhctest
  partitions => # Root drive
part /boot      --size 100 --ondisk sda
part swap       --size 2000 --ondisk sda
part /          --size 6000 --ondisk sda
part /usr/cache --size 4000 --grow --ondisk sda
# Second drive
part swap       --size 2000 --ondisk sdb
part swap       --size 2000 --ondisk sdb
part /usr/pic1 --size 16000 --ondisk sdb
part /usr/render_tmp --size 12000 --grow --ondisk sdb
  pxt:trap => rhn:kickstart-create-options-cb
  root_password_1 => kickstart
  root_password_2 => kickstart
  static_ip_iface => 
  success_redir => select_options.pxt
  timezone => America/Los_Angeles

User Information:
  User lcarstensen (id 1, org_id 1)

Error notes:
  (none)

Initial Request:
  Yes

Error message:
  A line with label 'swap' already exists. at
/usr/lib/perl5/site_perl/5.6.1/i386-linux/RHN/Kickstart/Multi.pm line 27.


Version-Release number of selected component (if applicable):
rhn-base-3.0.0-4

How reproducible:
Always

Steps to Reproduce:
1.  Create a kickstart profile.
2.  Try and update the partitioning section to match the one listed
above in the desciption.
3.  Crash.

Additional info:
Comment 1 Robin Norwood 2004-03-08 13:10:02 EST
Fixed for the next satellite release.

*** This bug has been marked as a duplicate of 115029 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:25 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.