Bug 1121651 - gimp-help-browser moved to Optional. Causes yum update to break.
Summary: gimp-help-browser moved to Optional. Causes yum update to break.
Keywords:
Status: CLOSED DUPLICATE of bug 1152849
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng
Version: 6.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Lubos Kocman
QA Contact: Release Test Team
URL:
Whiteboard:
: 1134708 (view as bug list)
Depends On: 1119340
Blocks: 1011602 1083985
TreeView+ depends on / blocked
 
Reported: 2014-07-21 13:29 UTC by Alexander Todorov
Modified: 2018-12-09 18:27 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-30 08:16:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1185823 None None None 2018-12-09 18:27:51 UTC

Description Alexander Todorov 2014-07-21 13:29:51 UTC
Description of problem:

Trying to upgrade a 6.5 system to latest 6.6:

Error: Package: 2:gimp-help-browser-2.6.9-4.el6_3.3.x86_64 (@anaconda-RedHatEnterpriseLinux-201311111358.x86_64/6.5)
           Requires: libwebkit-1.0.so.2()(64bit)
           Removing: webkitgtk-1.2.6-5.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201311111358.x86_64/6.5)
               libwebkit-1.0.so.2()(64bit)
           Updated By: webkitgtk-1.4.3-2.el6.x86_64 (beaker-Server)
               Not found
Error: Package: 2:gimp-help-browser-2.6.9-4.el6_3.3.x86_64 (@anaconda-RedHatEnterpriseLinux-201311111358.x86_64/6.5)
           Requires: gimp(x86-64) = 2:2.6.9-4.el6_3.3
           Removing: 2:gimp-2.6.9-4.el6_3.3.x86_64 (@anaconda-RedHatEnterpriseLinux-201311111358.x86_64/6.5)
               gimp(x86-64) = 2:2.6.9-4.el6_3.3
           Updated By: 2:gimp-2.6.9-7.el6.x86_64 (beaker-Server)
               gimp(x86-64) = 2:2.6.9-7.el6

Comment 3 Alexander Todorov 2014-07-23 09:58:24 UTC
Move gimp-help-browser back to the main repo.

Comment 4 Lubos Kocman 2014-07-23 10:02:55 UTC
Hello,

this is actually expected. Caused by Bug 1119340.
This could be returned back in case that we'd find another solution.

Lubos

Comment 5 Dennis Gregorovic 2014-07-23 10:13:20 UTC
(In reply to Lubos Kocman from comment #4)
> Hello,
> 
> this is actually expected. Caused by Bug 1119340.
> This could be returned back in case that we'd find another solution.
> 
> Lubos

We can't move packages from base to Optional because customers aren't guaranteed to have the optional channel enabled and so their upgrades will fail.  That was one of the motivations behind the "prepopulate" code in distill.

Comment 6 Lubos Kocman 2014-07-23 10:22:39 UTC
Hello Dennis,

yes I know dennis. I had to remove these from prepopulate as well. So far this was "temp solution" that we agreed on with snagar.

Lubos

Comment 7 Marian Ganisin 2014-08-12 06:28:43 UTC
Bug 1119340

Comment 8 Nils Philippsen 2014-09-02 14:12:55 UTC
*** Bug 1134708 has been marked as a duplicate of this bug. ***

Comment 9 Lubos Kocman 2014-10-30 14:53:47 UTC

*** This bug has been marked as a duplicate of bug 1152849 ***


Note You need to log in before you can comment on or make changes to this bug.