Bug 1121654 - No keyboard in password recovery console
Summary: No keyboard in password recovery console
Keywords:
Status: CLOSED DUPLICATE of bug 1098332
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: dracut-maint
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 13:35 UTC by Allan Mullan
Modified: 2017-04-11 13:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: When editing the grub config on boot, you need to take out 'rhgb' from the kernel line when adding in init=/bin/sh Consequence: The keyboard doesn't work correctly Fix: Remove 'rhgb' from kernel line Result: Keyboard works perfectly.
Clone Of:
Environment:
Last Closed: 2014-11-11 12:19:06 UTC


Attachments (Terms of Use)
Kernel Panic when exiting recovery console (22.38 KB, image/png)
2014-07-21 13:50 UTC, Allan Mullan
no flags Details

Description Allan Mullan 2014-07-21 13:35:49 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Allan Mullan 2014-07-21 13:42:38 UTC
Apologies, knocked enter and it somehow submitted form.

Description of problem: Issue when trying to use keyboard in recovery mode (init=/bin/sh)

Version-Release number of selected component (if applicable): RHEL 7


How reproducible: Every time


Steps to Reproduce:
1. At the grub screen, press E
2. Add init=/bin/sh to end of linux kernel line and press Ctrl+X

Actual results: When booted, you won't have proper keyboard functionality


Expected results: Keyboard should work as expected


Additional info: Removing 'rhgb' fixes the issue.

Comment 3 Allan Mullan 2014-07-21 13:50:08 UTC
Also, whilst in this mode. If you mount the / filesystem and change the password for a user it doesn't update.

AND, if you 'exit' (or Ctrl-D) you get a kernel panic. I'll attach a screenshot from my virtualbox guest.

Did anyone actually test this stuff before releasing? Seems odd that such a reasonably vital piece of functionality doesn't work..?

Comment 4 Allan Mullan 2014-07-21 13:50:50 UTC
Created attachment 919637 [details]
Kernel Panic when exiting recovery console

Comment 5 Allan Mullan 2014-07-21 14:15:56 UTC
FYI - When updating the password the shadow file DOES get updated but I'm not sure with what. A colleague and I both tried to reset passwords for different accounts on different boxes and we can't use those accounts anymore. The password definitely gets updated but not sure what with.

Comment 6 Harald Hoyer 2014-08-14 12:12:15 UTC
"init=/bin/sh" is NOT THE RECOVERY CONSOLE!

Exiting does of course kernel panic, because the shell is PID 1!

You better boot into recovery mode by adding "s" or "1" to the kernel command line.

Peter Jones: do you even read the bug reports before you assign them to dracut?

Comment 7 David Cantrell 2014-11-06 19:57:10 UTC
Harald:

Your description sounds like perfect material for documentation, a kbase article, or any of a number of other documentation areas.

Given that the problem reported is not with the boot loader, but what happens after, Peter reassigned it to you as the next troubleshooter.  Since the kernel does actually boot, the next thing on the list would be dracut's area.  Rather than immediately send the bug back to where it came from, it would be helpful if you could take the next step with what needs to happen on the bug.  In this particular case, you have provided an explanation suitable for documentation.  As a reminder, grub2 does not own documentation for RHEL.  I recommend reassigning this to the documentation team and following up with them to ensure the clarification is there.  Additionally, any areas of documentation that may be helpful for RHEL users with this information, feel free to update.

Thanks.

Comment 8 Harald Hoyer 2014-11-11 12:16:22 UTC
see also:
https://bugzilla.redhat.com/show_bug.cgi?id=1045574

Comment 9 Harald Hoyer 2014-11-11 12:19:06 UTC
Anyway, this is most likely a dup of: bug 1098332

*** This bug has been marked as a duplicate of bug 1098332 ***


Note You need to log in before you can comment on or make changes to this bug.