Bug 1121679 - [QE] (EAP-6.3.0) Installation of EAP 6.3.0 errata for RHEL7 ppc64is failing with wrong dependencies
Summary: [QE] (EAP-6.3.0) Installation of EAP 6.3.0 errata for RHEL7 ppc64is failing w...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: RPMs
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ER10
: EAP 6.3.0
Assignee: Christopher O'Brien
QA Contact: Katerina Odabasi
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 14:52 UTC by Katerina Odabasi
Modified: 2016-08-02 16:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-02 16:00:29 UTC
Type: Bug


Attachments (Terms of Use)
List of visible packages (31.11 KB, text/plain)
2014-07-21 15:20 UTC, Katerina Odabasi
no flags Details

Description Katerina Odabasi 2014-07-21 14:52:24 UTC
Description of problem:
Installation of EAP 6.3.0 errata for RHEL7 ppc64 (2013:14389) is failing with wrong dependencies.

For this reason the TPS tests failed. The TPS tests are mandatory part of the standard Errata testing process. The following testing phases of RPMs are blocked by this issue and we can't continue with testing for RHEL7. For this reason it is a blocker for RHEL7 RPM distro.

Details:
Errata does not see all packages under build tab:
193 packages are seen by ET as new package
ET contains 241 brew builds in total.

For example these packages are included in the build and are not seen as new packages:
jaxws-jboss-httpserver-httpspi-1.0.1-3.GA_redhat_2.ep6.el7.3
jboss-annotations-api_1.1_spec-1.0.1-3.2.Final_redhat_2.ep6.el7
jboss-common-core-2.2.17-10.GA_redhat_2.ep6.el7

For this reason installation fails.

Comment 1 Christopher O'Brien 2014-07-21 15:12:34 UTC
There is (correctly) no released package information for RHEL-7-JBEAP-6 in the errata tool at this time. Please clarify your issue.

Comment 2 Katerina Odabasi 2014-07-21 15:20:02 UTC
The issue is not matter of released(old) packages, these are correctly empty. But when TPS makes attempt to install the packages from errata, it doesn't see all of the new builds. It tries to install packages which it is aware about, which is currently 193 from 241 packages in total.

Please see attachment for list of packages which are visible.

Comment 3 Katerina Odabasi 2014-07-21 15:20:57 UTC
Created attachment 919673 [details]
List of visible packages

Comment 4 Christopher O'Brien 2014-07-21 15:58:15 UTC
I see, you're not getting a package listing for some of the builds on ppc64. I'm looking into this now. Confirmed that the list from ER10 reflects the same packages missing

http://download.devel.redhat.com/devel/candidates/JBEAP/JBEAP-6.3.0.ER10/errata/14389.txt

Looking into this now. It could be as simple as some packages were added to the errata before the PPC64 arch was added.

Comment 5 Christopher O'Brien 2014-07-21 16:36:20 UTC
Did a mass reload of the file listing in the RHEL-7-JBEAP-6 errata, and that resulted in the rhn-advisory-file listing now associating more packages with the ppc64 channel

http://download.lab.bos.redhat.com/devel/candidates/JBEAP/JBEAP-6.3.0.ER10/errata/update.14389.txt

I believe this should resolve the issue, and I'm glad you discovered it.


Note You need to log in before you can comment on or make changes to this bug.