Bug 11217 - Upgrade from 6.0 -> 6.2 fails on findUpgradeSet
Summary: Upgrade from 6.0 -> 6.2 fails on findUpgradeSet
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brock Organ
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-04 15:59 UTC by Cade Bodley
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-02 20:49:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Cade Bodley 2000-05-04 15:59:24 UTC
When choosing to upgrade the install fails while attempting to find
packages to upgrade.  The error message, more or less, is as follows:

File "/usr/bin/anaconda" line 342 in ?
  inff.run(todo, test = test)
File "/usr/lib/anaconda/text.py", line 1163, in run
  rc = apply(step[1], (dir,) + step[2],
File "/usr/lib/anaconda/text.py", line 317, in
  __call__
  todo.upgradeFilePackages(root)
in File "/usr/lib/anaconda/todo.py", line 730
packages = rpm.findUpgradeSet

If there was some way to tell which package it was choking on I'd jusr
remove that package.  I tried rpm --rebuilddb and that didn't make any
difference.

Comment 1 Jay Turner 2000-05-04 20:08:59 UTC
This message is generally a result of the root partition not getting mounted
during the upgrade.  Do me a favor and send me the output of "fdisk -l" for all
of the drives on the system.  In addition, please submit a copy of your
/etc/fstab file.

Comment 2 jmp 2000-05-23 21:06:59 UTC
Same here. This is a sparc (SS10), RH6.1 upgrade to 6.2.
Problem is in anaconda, fstab.py.
UFS partitions (or anything not "ext2" nor "swap") are _ignored_.

Problem is, only the root partition is ext2.
Others are UFS and NFS. Namely, /var/lib/rpm/ lives in UFS...
There are some lines of interest commented out. Line 520:
"# XXX code from sparc merge". I guess we sparc users were left out...

Comment 3 Michael Fulbright 2000-10-04 18:46:27 UTC
Do you happen to have any symlinks for directories like /tmp, /home, etc?

Comment 4 Brock Organ 2000-11-02 20:49:22 UTC
I am unable to reproduce this behavior in test here ... please reopen if you are
having this problem with 7 ... thanks for your report!


Note You need to log in before you can comment on or make changes to this bug.