Bug 1121708 - "Messages" described incorrectly
Summary: "Messages" described incorrectly
Keywords:
Status: CLOSED DUPLICATE of bug 1157468
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Documentation
Version: 6.0.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Vikram Goyal
QA Contact: Marek Baluch
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 16:36 UTC by Andrea Ubbiali
Modified: 2015-05-06 01:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Build Name: 22688, User Guide-6.0-1 Build Date: 30-06-2014 17:07:57 Topic ID: 13576-592079 [Latest]
Last Closed: 2015-05-06 01:52:12 UTC
Type: Bug


Attachments (Terms of Use)

Description Andrea Ubbiali 2014-07-21 16:36:48 UTC
Title: Messages

Describe the issue: CONTRADICTION in definition of BPMN 2.0 messages. in one pargraph they are said to be meant for communication with EXTERNAL systems, and in the description, exactly the opposite is stated


Suggestions for improvement:

Ask ENGINEERING to describe the actual behavior


Additional information:

A.3. Collaboration mechanisms
Elements with execution semantics make use of general collaboration mechanisms. Different Elements allow you to access and use the mechanism in a different way; for example, there is a mechanism called signalling: a Signal is sent by a Throw Signal Intermediate Event Element and received by a Catch Signal Intermediate Event (two Elements with execution semantics make use of the same Signal mechanism).
Collaboration mechanism include the following:

    Messages: intended primarily for communication with other systems especially if a complex data type is required (it is possible ton define a Message structure that can become a process variable)
    Escalations: mainly inter-process (between processes) signalling of escalation to trigger escalation handling
    Errors: mainly inter-process signalling of escalation to trigger escalation handling
    Signals: general, mainly inter-process instance communication 

All the events are managed by the signaling mechanism. To distinguish individual objects of individual mechnism the signal use different signal codes or names.
Report a bug
⁠A.3.1. Messages
“A Message represents the content of a communication between two Participants. In BPMN 2.0, a Message is a graphical decorator (it was a supporting element in BPMN 1.2). An ItemDefinition is used to specify the Message structure. ⁠[1]”
Messages are objects that can be send between Processes or Process elements, that participate in the respective communication; Messages are ment for inter-Process communication, not for communication with other external systems. They are send by the Message Intermadiate Throw Events and Send Tasks, and can be consumed by the Message Start Events, Message Intermediate Catch Events, Message End Events, and Receive Tasks. One Message can be consumed by an arbitrary number of Processes and Process elements.

Comment 2 Vikram Goyal 2015-05-06 01:52:12 UTC

*** This bug has been marked as a duplicate of bug 1157468 ***


Note You need to log in before you can comment on or make changes to this bug.