Bug 1121720 - Unable to set IPv6 DNS addresses
Summary: Unable to set IPv6 DNS addresses
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 17:26 UTC by Bill C. Riemers
Modified: 2015-06-29 21:40 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-29 21:40:47 UTC


Attachments (Terms of Use)
Values I apply (42.16 KB, image/png)
2014-07-21 20:44 UTC, Bill C. Riemers
no flags Details
Values I see next time I open the same dialog (39.93 KB, image/png)
2014-07-21 20:45 UTC, Bill C. Riemers
no flags Details

Description Bill C. Riemers 2014-07-21 17:26:31 UTC
Description of problem:

NetworkManager happily allows one to enable IPv6 for an OpenVPN connection.  However, the actual values are neither used no correctly parsed.  In this case, I tried adding some IPv6 DNS addresses.  If IPv6 is completely broken like this, it shouldn't even be a configuration option.

NetworkManager-openvpn

Version-Release number of selected component (if applicable):

NetworkManager-openvpn-0.9.9.0-0.1.git20140128.fc20.x86_64
NetworkManager-openvpn-gnome-0.9.9.0-0.1.git20140128.fc20.x86_64
NetworkManager-vpnc-0.9.8.2-2.fc20.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Edit an openvpn configuration.
2. Click on IPv6
3. Manually add IPv6 DNS addresses (In my test I tried ::1, fe80::beae:c5ff:fee8:b5e, and fe80::4a5b:39ff:fe25:fe)
4. Click apply
5. Close
6. Re-open

Actual results:

IPv6 Addresses are converted to bugus IPv4 addresses, which won't be added to /etc/resolv.conf when connecting (fortunately).

Expected results:

IPv6 addresses should remain IPv6 addresses and added to the /etc/resolv.conf files.


Additional info:

Comment 1 Thomas Haller 2014-07-21 18:38:01 UTC
I cannot reproduce this. Could you explain more in detail at which point you see bogus IPv4 addresses?

Comment 2 Bill C. Riemers 2014-07-21 20:44:41 UTC
Created attachment 919752 [details]
Values I apply

Comment 3 Bill C. Riemers 2014-07-21 20:45:22 UTC
Created attachment 919753 [details]
Values I see next time I open the same dialog

Comment 4 Bill C. Riemers 2014-07-21 20:46:17 UTC
I attached the screen shots.  Please let me know if you need me to specify how I navigate to these dialogs.

Comment 5 Thomas Haller 2014-07-21 21:03:27 UTC
Ah. This is gnome-control-center UI, I can reproduce it easily.

AFAIS, nm-applet (and nm-connection-editor) is not affected.

I update the component of the UI.

Comment 6 Quentin Armitage 2014-11-28 16:46:51 UTC
This problem still exists in F21-RC1.

It appears that the control-center is causing the correct DNS server IPv6 addresses to be written to the /etc/sysconfig/network-scripts/ifcfg-IFACE file. However when it displays the addresses, it displays them as IPv4 addresses. The addresses displayed are the first 4 octets of the IPv6 adddress, but displayed in decimal IPv4 notation. For example, if I enter an IPv6 DNS server address 2001:470:1234:5::17, the IPv4 address displayed is 32.1.4.112 (i.e. 0x20.0x01.0x04.0x70 in decimal).

The IPv6 address and Gateway are correctly displayed as IPv6 addresses.

Comment 7 Fedora End Of Life 2015-05-29 12:25:50 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 8 Fedora End Of Life 2015-06-29 21:40:47 UTC
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.