Bug 1121761 - Server: SELinux failures prevent login into cockpit
Summary: Server: SELinux failures prevent login into cockpit
Keywords:
Status: CLOSED DUPLICATE of bug 1110758
Alias: None
Product: Fedora
Classification: Fedora
Component: cockpit
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Patrick Uiterwijk
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F21AlphaBlocker cockpit-F21-tracker
TreeView+ depends on / blocked
 
Reported: 2014-07-21 19:36 UTC by Miloslav Trmač
Modified: 2014-07-22 08:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-22 08:41:21 UTC


Attachments (Terms of Use)
Relevant AVC (1.30 KB, text/plain)
2014-07-21 19:36 UTC, Miloslav Trmač
no flags Details

Description Miloslav Trmač 2014-07-21 19:36:38 UTC
Created attachment 919747 [details]
Relevant AVC

Description of problem:
cockpit shows the login screen, but login isn't possible.

Version-Release number of selected component (if applicable):
cockpit-0.16-1.fc21.x86_64
selinux-policy-3.13.1-65.fc21.noarch
(full disclosure: on a custom DVD build, using fedora-install-server.ks)

How reproducible:


Steps to Reproduce:
1. Enable cockpit.socket and the service in firewalld, try to connect to :1001
2. Enter root user name and password
3. See nothing happen

Comment 1 Miloslav Trmač 2014-07-21 19:47:52 UTC
(In reply to Miloslav Trmač from comment #0)
> 3. See nothing happen
Eventually, the dialog says
> Cockpit not available: shell not installed correctly

Comment 2 Miloslav Trmač 2014-07-21 19:52:02 UTC
(… and (setenforce 0) does show the post-login screen, and briefly a server icon in the list, but the server disappears immediately.  Adding “localhost” as a server then doesn’t work.)

Comment 3 Stef Walter 2014-07-22 08:41:21 UTC

*** This bug has been marked as a duplicate of bug 1110758 ***

Comment 4 Stef Walter 2014-07-22 08:42:32 UTC
This has the same AVC's as bug #1110758


Note You need to log in before you can comment on or make changes to this bug.