Bug 1121787 - "Failed to call refresh: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]" on RHEL7
Summary: "Failed to call refresh: /usr/sbin/foreman-rake db:seed returned 1 instead of...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Og Maciel
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1130265 1133497 (view as bug list)
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker
TreeView+ depends on / blocked
 
Reported: 2014-07-21 21:19 UTC by Jan Hutař
Modified: 2016-04-22 15:57 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:24:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 7104 None None None 2016-04-22 15:57:46 UTC

Description Jan Hutař 2014-07-21 21:19:38 UTC
Description of problem:
katello-installer complains "wrong number of arguments (2 for 1)" on RHEL7


Version-Release number of selected component (if applicable):
Satellite-6.0.4-RHEL-7-20140716.0


How reproducible:
always


Steps to Reproduce:
1. Install Satellite6 on RHEL7 system
   # katello-installer --foreman-admin-email 'root@localhost' \
     --foreman-admin-username 'admin' --foreman-admin-password '<password>'


Actual results:
katello-installer exits with 6


Expected results:
Should work and exit with 0


Additional info:
Relevant part of /var/log/katello-installer/katello-installer.log:
[...]
[ INFO 2014-07-20 18:33:14 main]  RESOURCE Exec[restart_foreman]
[DEBUG 2014-07-20 18:33:14 main]  Exec[foreman_certs_config](provider=posix): Executing check '/usr/share/foreman/script/foreman-config      -k ssl_ca_file -v '/etc/foreman/client_ca.pem'      -k ssl_certificate -v '/etc/foreman/client_cert.pem'      -k ssl_priv_key -v '/etc/foreman/client_key.pem' --dry-run'
[DEBUG 2014-07-20 18:33:14 main]  Executing '/usr/share/foreman/script/foreman-config      -k ssl_ca_file -v '/etc/foreman/client_ca.pem'      -k ssl_certificate -v '/etc/foreman/client_cert.pem'      -k ssl_priv_key -v '/etc/foreman/client_key.pem' --dry-run'
[DEBUG 2014-07-20 18:36:23 main]  /Stage[main]/Certs::Foreman/Exec[foreman_certs_config]/unless: /etc/foreman/client_ca.pem
[DEBUG 2014-07-20 18:36:23 main]  /Stage[main]/Certs::Foreman/Exec[foreman_certs_config]/unless: /etc/foreman/client_cert.pem
[DEBUG 2014-07-20 18:36:23 main]  /Stage[main]/Certs::Foreman/Exec[foreman_certs_config]/unless: /etc/foreman/client_key.pem
[DEBUG 2014-07-20 18:36:23 main]  Exec[foreman_certs_config](provider=posix): Executing '/usr/share/foreman/script/foreman-config      -k ssl_ca_file -v '/etc/foreman/client_ca.pem'      -k ssl_certificate -v '/etc/foreman/client_cert.pem'      -k ssl_priv_key -v '/etc/foreman/client_key.pem''
[DEBUG 2014-07-20 18:36:23 main]  Executing '/usr/share/foreman/script/foreman-config      -k ssl_ca_file -v '/etc/foreman/client_ca.pem'      -k ssl_certificate -v '/etc/foreman/client_cert.pem'      -k ssl_priv_key -v '/etc/foreman/client_key.pem''
[ WARN 2014-07-20 18:39:15 main]  /Stage[main]/Certs::Foreman/Exec[foreman_certs_config]/returns: executed successfully
[ INFO 2014-07-20 18:39:15 main]  RESOURCE Exec[foreman_certs_config]
[DEBUG 2014-07-20 18:39:15 main]  /Stage[main]/Certs::Foreman/Exec[foreman_certs_config]: The container Class[Certs::Foreman] will propagate my refresh event
[DEBUG 2014-07-20 18:39:15 main]  Class[Certs::Foreman]: The container Stage[main] will propagate my refresh event
[ INFO 2014-07-20 18:39:19 main] E, [2014-07-20T18:39:19.011251 #13628] ERROR -- : 500 Internal Server Error
[ INFO 2014-07-20 18:39:19 main] {
[ INFO 2014-07-20 18:39:19 main]     "error" => {
[ INFO 2014-07-20 18:39:19 main]         "message" => "wrong number of arguments (2 for 1)"
[ INFO 2014-07-20 18:39:19 main]     }
[ INFO 2014-07-20 18:39:19 main] }
[ERROR 2014-07-20 18:39:19 main]  /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[<fqdn>]: Could not evaluate: 500 Internal Server Error
[ INFO 2014-07-20 18:39:19 main] /usr/share/gems/gems/rest-client-1.6.7/lib/restclient/abstract_response.rb:48:in `return!'
[ INFO 2014-07-20 18:39:19 main] /usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:230:in `process_result'
[ INFO 2014-07-20 18:39:19 main] /usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:178:in `block in transmit'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/net/http.rb:852:in `start'
[ INFO 2014-07-20 18:39:19 main] /usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:172:in `transmit'
[ INFO 2014-07-20 18:39:19 main] /usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:64:in `execute'
[ INFO 2014-07-20 18:39:19 main] /usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:33:in `execute'
[ INFO 2014-07-20 18:39:19 main] /usr/share/gems/gems/rest-client-1.6.7/lib/restclient/resource.rb:51:in `get'
[ INFO 2014-07-20 18:39:19 main] /usr/share/gems/gems/apipie-bindings-0.0.8/lib/apipie_bindings/api.rb:195:in `http_call'
[ INFO 2014-07-20 18:39:19 main] /usr/share/gems/gems/apipie-bindings-0.0.8/lib/apipie_bindings/api.rb:150:in `call'
[ INFO 2014-07-20 18:39:19 main] /usr/share/gems/gems/apipie-bindings-0.0.8/lib/apipie_bindings/resource.rb:14:in `call'
[ INFO 2014-07-20 18:39:19 main] /usr/share/katello-installer/modules/foreman/lib/puppet/provider/foreman_smartproxy/rest_v2.rb:29:in `proxy'
[ INFO 2014-07-20 18:39:19 main] /usr/share/katello-installer/modules/foreman/lib/puppet/provider/foreman_smartproxy/rest_v2.rb:34:in `id'
[ INFO 2014-07-20 18:39:19 main] /usr/share/katello-installer/modules/foreman/lib/puppet/provider/foreman_smartproxy/rest_v2.rb:38:in `exists?'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/property/ensure.rb:81:in `retrieve'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/type.rb:1035:in `retrieve'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/type.rb:1063:in `retrieve_resource'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/transaction/resource_harness.rb:223:in `from_resource'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/transaction/resource_harness.rb:19:in `evaluate'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/transaction.rb:174:in `apply'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/transaction.rb:187:in `eval_resource'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/transaction.rb:117:in `call'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/transaction.rb:117:in `block (2 levels) in evaluate'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/util.rb:327:in `block in thinmark'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/benchmark.rb:296:in `realtime'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/util.rb:326:in `thinmark'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/transaction.rb:117:in `block in evaluate'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/graph/relationship_graph.rb:118:in `traverse'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/transaction.rb:108:in `evaluate'
[ INFO 2014-07-20 18:39:19 main] /usr/share/gems/gems/kafo-0.6.4/modules/kafo_configure/lib/puppet/parser/functions/add_progress.rb:25:in `evaluate_with_trigger'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/resource/catalog.rb:167:in `block in apply'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/util/log.rb:149:in `with_destination'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/transaction/report.rb:112:in `as_logging_destination'
[ INFO 2014-07-20 18:39:19 main] /usr/share/gems/gems/kafo-0.6.4/modules/kafo_configure/lib/kafo/puppet/report_wrapper.rb:30:in `method_missing'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/resource/catalog.rb:166:in `apply'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/configurer.rb:117:in `block in apply_catalog'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/util.rb:161:in `block in benchmark'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/benchmark.rb:296:in `realtime'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/util.rb:160:in `benchmark'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/configurer.rb:116:in `apply_catalog'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/configurer.rb:191:in `run'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/application/apply.rb:288:in `apply_catalog'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/application/apply.rb:228:in `block in main'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/context.rb:64:in `override'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet.rb:234:in `override'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/application/apply.rb:190:in `main'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/application/apply.rb:151:in `run_command'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/application.rb:371:in `block (2 levels) in run'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/application.rb:477:in `plugin_hook'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/application.rb:371:in `block in run'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/util.rb:479:in `exit_on_fail'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/application.rb:371:in `run'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/util/command_line.rb:137:in `run'
[ INFO 2014-07-20 18:39:19 main] /usr/share/ruby/vendor_ruby/puppet/util/command_line.rb:91:in `execute'
[ INFO 2014-07-20 18:39:19 main] /usr/bin/puppet:8:in `<main>'
[ INFO 2014-07-20 18:39:19 main]  RESOURCE Foreman_smartproxy[<fqdn>]
[DEBUG 2014-07-20 18:39:19 main]  Finishing transaction 33395040
[DEBUG 2014-07-20 18:39:19 main]  Storing state
[DEBUG 2014-07-20 18:39:19 main]  Stored state in 0.37 seconds
[ WARN 2014-07-20 18:39:19 main]  Finished catalog run in 559.81 seconds
[DEBUG 2014-07-20 18:39:19 main]  Using settings: adding file resource 'rrddir': 'File[/var/lib/puppet/rrd]{:path=>"/var/lib/puppet/rrd", :mode=>"750", :owner=>"puppet", :group=>"puppet", :ensure=>:directory, :loglevel=>:debug, :links=>:follow, :backup=>false}'
[DEBUG 2014-07-20 18:39:19 main]  /File[/var/lib/puppet/rrd]/seluser: Found seluser default 'system_u' for /var/lib/puppet/rrd
[DEBUG 2014-07-20 18:39:19 main]  /File[/var/lib/puppet/rrd]/selrole: Found selrole default 'object_r' for /var/lib/puppet/rrd
[DEBUG 2014-07-20 18:39:19 main]  /File[/var/lib/puppet/rrd]/seltype: Found seltype default 'puppet_var_lib_t' for /var/lib/puppet/rrd
[DEBUG 2014-07-20 18:39:19 main]  /File[/var/lib/puppet/rrd]/selrange: Found selrange default 's0' for /var/lib/puppet/rrd
[DEBUG 2014-07-20 18:39:19 main]  Finishing transaction 40716620
[DEBUG 2014-07-20 18:39:19 main]  Received report to process from <fqdn>
[DEBUG 2014-07-20 18:39:19 main]  Processing report from <fqdn> with processor Puppet::Reports::Store
[ INFO 2014-07-20 18:39:28 main] Puppet has finished, bye!
[ INFO 2014-07-20 18:39:28 main] Executing hooks in group post
[DEBUG 2014-07-20 18:39:28 main] Hook /usr/share/katello-installer/hooks/post/10-post_install.rb returned nil
[ INFO 2014-07-20 18:39:28 main] All hooks in group post finished
[DEBUG 2014-07-20 18:39:28 main] Exit with status code: 6 (signal was 6)
[ERROR 2014-07-20 18:39:28 main] Repeating errors encountered during run:
[ERROR 2014-07-20 18:39:28 main]  /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[<fqdn>]: Could not evaluate: 500 Internal Server Error
[DEBUG 2014-07-20 18:39:28 main] Cleaning /etc/katello-installer/d20140720-13163-1ttiotk
[DEBUG 2014-07-20 18:39:28 main] Cleaning /tmp/default_values.yaml

Comment 2 Dominic Cleal 2014-07-24 13:51:29 UTC
Could you attach foreman-debug when this happens?  It looks like an error coming from the server's API back to the installer, so the full stack trace should be captured in production.log.

Comment 4 Fernando 2014-07-28 11:33:40 UTC
Hi

I have exactly the same problem when i installing katello (Sat6BETA) on rhel-6.5. 

My Production Log pushing me: (i replaced my FQDN with "myhost")

Connection refused - "/usr/share/foreman/tmp/sockets/dynflow_socket" (Errno::ECONNREFUSED)
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.1/lib/dynflow/executors/remote_via_socket/core.rb:142:in `initialize'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.1/lib/dynflow/executors/remote_via_socket/core.rb:142:in `new'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.1/lib/dynflow/executors/remote_via_socket/core.rb:142:in `connect'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.1/lib/dynflow/executors/remote_via_socket/core.rb:70:in `delayed_initialize'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.1/lib/dynflow/micro_actor.rb:95:in `run'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.1/lib/dynflow/micro_actor.rb:13:in `block in initialize'
/opt/rh/ruby193/root/usr/share/gems/gems/logging-1.8.1/lib/logging/diagnostic_context.rb:323:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/logging-1.8.1/lib/logging/diagnostic_context.rb:323:in `block in create_with_logging_context'
Processing by HostsController#externalNodes as YML
  Parameters: {"name"=>"myhost"}
No Capsule server found on ["myhost"] and is not in trusted_puppetmaster_hosts
Redirected to https://myhost/users/login
Filter chain halted as :require_puppetmaster_or_login rendered or redirected
Completed 403 Forbidden in 20ms (ActiveRecord: 2.8ms)
Processing by Api::V2::HostsController#facts as JSON
  Parameters: {"facts"=>"[FILTERED]", "name"=>"myhost", "certname"=>"myhost", "apiv"=>"v2", "host"=>{"facts"=>"[FILTERED]", "name"=>"myhost", "certname"=>"myhost"}}
No Capsule server found on ["myhost"] and is not in trusted_puppetmaster_hosts
  Rendered api/v2/errors/access_denied.json.rabl within api/v2/layouts/error_layout (0.7ms)
Filter chain halted as :require_puppetmaster_or_login rendered or redirected
Completed 403 Forbidden in 8ms (Views: 1.3ms | ActiveRecord: 1.7ms)
Processing by HostsController#externalNodes as YML
  Parameters: {"name"=>"myhost"}
No Capsule server found on ["myhost"] and is not in trusted_puppetmaster_hosts
Redirected to https://myhost/users/login
Filter chain halted as :require_puppetmaster_or_login rendered or redirected
Completed 403 Forbidden in 6ms (ActiveRecord: 0.8ms)
Processing by Api::V2::ReportsController#create as JSON
  Parameters: {"report"=>"[FILTERED]", "apiv"=>"v2"}
No Capsule server found on ["myhost"] and is not in trusted_puppetmaster_hosts
  Rendered api/v2/errors/access_denied.json.rabl within api/v2/layouts/error_layout (0.6ms)
Filter chain halted as :require_puppetmaster_or_login rendered or redirected
Completed 403 Forbidden in 167ms (Views: 1.4ms | ActiveRecord: 0.9ms)


may you can give me a hint for solving this issue, thank you.

BR
Fernando

Comment 6 Jan Hutař 2014-08-04 08:05:05 UTC
Changing title of the bugzilla so it reflects first issue encountered. This seems to be nicely reproducible so if any other info is needed, please let me know.

Comment 7 Jan Hutař 2014-08-04 08:12:20 UTC
(In reply to Fernando from comment #4)
> Hi
> 
> I have exactly the same problem when i installing katello (Sat6BETA) on
> rhel-6.5. 
> 
> My Production Log pushing me: (i replaced my FQDN with "myhost")
> [...]

Hello, I believe you have different issue (you are on RHEL6 and error message seems to be different). I do recommend to work with Red Hat support.

Comment 8 Corey Welton 2014-08-11 17:21:51 UTC
This will basically get tested in installing against RHEL7.  If the install works, we should be ok.

Comment 12 Eric Helms 2014-08-15 14:05:28 UTC
Created redmine issue http://projects.theforeman.org/issues/7104 from this bug

Comment 13 Eric Helms 2014-08-15 15:54:00 UTC
I believe this bug is related to https://bugzilla.redhat.com/show_bug.cgi?id=1130265 looking at the logs. It would appear the seeds are not finishing due to the qpid config error and thus the users are not seeded properly leading to the Foreman proxy error.

Comment 14 Ivan Necas 2014-08-25 15:13:17 UTC
*** Bug 1133497 has been marked as a duplicate of this bug. ***

Comment 15 Ivan Necas 2014-08-27 16:52:44 UTC
Updates merged in https://github.com/Katello/katello-installer/pull/112

Comment 17 Mike McCune 2014-08-27 19:29:46 UTC
*** Bug 1130265 has been marked as a duplicate of this bug. ***

Comment 19 Og Maciel 2014-08-28 14:41:41 UTC
Failed QE

for i in `rpm -qa | grep -iE "^rubygem-hammer|^katello|^pulp|^candlepin|^foreman|^headpin|^thumbslug|^elasticsearch|ldap|signo|ruby193-rubygem-runcible" | sort`; do echo "* $i"; done

Comment 25 Ivan Necas 2014-08-29 06:29:43 UTC
@neha the issue should be definitely resolved with katello-installer-0.0.63-1.el7sat.noarch.rpm (comming with GA Snap 7 Compose 2 and later). Just to make sure still had the old version, what version of katello-installer you have on your system?

Comment 27 Og Maciel 2014-08-30 15:42:06 UTC
Verified:

Browser:
=====
* Firefox 31.0 (MacOS)

Build:  
====
* Satellite-6.0.4-RHEL-6-20140829.0

Packages:
======
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.23-1.el6_5.noarch
* candlepin-common-1.0.1-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.23-1.el6_5.noarch
* candlepin-tomcat6-0.9.23-1.el6_5.noarch
* elasticsearch-0.90.10-6.el6sat.noarch
* foreman-1.6.0.42-1.el6sat.noarch
* foreman-compute-1.6.0.42-1.el6sat.noarch
* foreman-gce-1.6.0.42-1.el6sat.noarch
* foreman-libvirt-1.6.0.42-1.el6sat.noarch
* foreman-ovirt-1.6.0.42-1.el6sat.noarch
* foreman-postgresql-1.6.0.42-1.el6sat.noarch
* foreman-proxy-1.6.0.30-1.el6sat.noarch
* foreman-selinux-1.6.0.14-1.el6sat.noarch
* foreman-vmware-1.6.0.42-1.el6sat.noarch
* katello-1.5.0-30.el6sat.noarch
* katello-ca-consumer-cloud-qe-10.idmqe.lab.eng.bos.redhat.com-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-default-ca-1.0-1.noarch
* katello-installer-0.0.64-1.el6sat.noarch
* katello-server-ca-1.0-1.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-0.3-4.el6sat.noarch
* pulp-nodes-common-2.4.1-0.5.rc1.el6sat.noarch
* pulp-nodes-parent-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-tools-2.4.1-0.5.rc1.el6sat.noarch
* pulp-rpm-plugins-2.4.1-0.6.beta.el6sat.noarch
* pulp-selinux-2.4.1-0.5.rc1.el6sat.noarch
* pulp-server-2.4.1-0.5.rc1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* rubygem-hammer_cli-0.1.1-12.el6sat.noarch
* rubygem-hammer_cli_foreman-0.1.1-16.el6sat.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.3-3.el6sat.noarch
* rubygem-hammer_cli_import-0.10.2-1.2.el6sat.noarch
* rubygem-hammer_cli_katello-0.0.4-14.el6sat.noarch

Browser:
=====
* Firefox 31.0 (MacOS)

Build:  
====
* Satellite/Satellite-6.0.4-RHEL-7-20140829.0

Packages:
======
* candlepin-0.9.23-1.el7.noarch
* candlepin-common-1.0.1-1.el7.noarch
* candlepin-guice-3.0-2_redhat_1.el7.noarch
* candlepin-scl-1-5.el7.noarch
* candlepin-scl-quartz-2.1.5-6.el7.noarch
* candlepin-scl-rhino-1.7R3-3.el7.noarch
* candlepin-scl-runtime-1-5.el7.noarch
* candlepin-selinux-0.9.23-1.el7.noarch
* candlepin-tomcat-0.9.23-1.el7.noarch
* elasticsearch-0.90.10-6.el7sat.noarch
* foreman-1.6.0.42-1.el7sat.noarch
* foreman-compute-1.6.0.42-1.el7sat.noarch
* foreman-gce-1.6.0.42-1.el7sat.noarch
* foreman-libvirt-1.6.0.42-1.el7sat.noarch
* foreman-ovirt-1.6.0.42-1.el7sat.noarch
* foreman-postgresql-1.6.0.42-1.el7sat.noarch
* foreman-proxy-1.6.0.30-1.el7sat.noarch
* foreman-selinux-1.6.0.14-1.el7sat.noarch
* foreman-vmware-1.6.0.42-1.el7sat.noarch
* katello-1.5.0-30.el7sat.noarch
* katello-certs-tools-1.5.6-1.el7sat.noarch
* katello-default-ca-1.0-1.noarch
* katello-installer-0.0.64-1.el7sat.noarch
* katello-server-ca-1.0-1.noarch
* openldap-2.4.39-3.el7.x86_64
* pulp-katello-0.3-4.el7sat.noarch
* pulp-nodes-common-2.4.1-0.5.rc1.el7sat.noarch
* pulp-nodes-parent-2.4.1-0.5.rc1.el7sat.noarch
* pulp-puppet-plugins-2.4.1-0.5.rc1.el7sat.noarch
* pulp-puppet-tools-2.4.1-0.5.rc1.el7sat.noarch
* pulp-rpm-plugins-2.4.1-0.6.beta.el7sat.noarch
* pulp-selinux-2.4.1-0.5.rc1.el7sat.noarch
* pulp-server-2.4.1-0.5.rc1.el7sat.noarch
* python-ldap-2.4.6-6.el7.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el7sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el7sat.noarch
* rubygem-hammer_cli-0.1.1-12.el7sat.noarch
* rubygem-hammer_cli_foreman-0.1.1-16.el7sat.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.3-3.el7sat.noarch
* rubygem-hammer_cli_import-0.10.2-1.2.el7sat.noarch
* rubygem-hammer_cli_katello-0.0.4-14.el7sat.noarch

Comment 31 Bryan Kearney 2014-09-11 12:24:24 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.