Bug 1121806 - /etc/passwd- , /etc/group- and /etc/.updated mislabeled in Fedora 21 and Rawhide live images
Summary: /etc/passwd- , /etc/group- and /etc/.updated mislabeled in Fedora 21 and Rawh...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 21
Hardware: All
OS: All
unspecified
urgent
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F21AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2014-07-21 23:35 UTC by Adam Williamson
Modified: 2014-07-26 18:55 UTC (History)
8 users (show)

Fixed In Version: systemd-215-5.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-26 18:54:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1121301 None None None Never

Internal Links: 1121301

Description Adam Williamson 2014-07-21 23:35:18 UTC
This bug is split off from https://bugzilla.redhat.com/show_bug.cgi?id=1121301 , as the mislabeling of three files in /etc is caused by systemd (according to Zbigniew) and seems to be a separate issue from the quasi-random mislabeling of hundreds of files in /usr and /var.

So, this bug covers the fact that since 2014-07-08, every F21 and F22 branch live image generated (the auto-generated nightlies, and the manually built Alpha TC1/TC2 compose attempts) has three mislabeled files in /etc:

/etc/passwd-
/etc/group-
/etc/.updated

restorecon reset /etc/.updated context system_u:object_r:etc_runtime_t:s0->system_u:object_r:etc_t:s0
restorecon reset /etc/passwd- context system_u:object_r:tmpfs_t:s0->system_u:object_r:passwd_file_t:s0
restorecon reset /etc/group- context system_u:object_r:tmpfs_t:s0->system_u:object_r:passwd_file_t:s0

the mislabelling of /etc/passwd- and /etc/group- is especially serious, as it causes the live images to fail to boot without enforcing=0 being passed. Hence, nominating this as an Alpha release blocker per https://fedoraproject.org/wiki/Fedora_21_Alpha_Release_Criteria#Release-blocking_images_must_boot , "All release-blocking images must boot in their supported configurations."

Comment 1 Zbigniew Jędrzejewski-Szmek 2014-07-22 12:18:34 UTC
We're not doing bodhi updates yet, right? Should be fixed in systemd-215-5.fc21.


Note You need to log in before you can comment on or make changes to this bug.