Bug 1121822 - Cmockery2 is being linked against gluster applications
Summary: Cmockery2 is being linked against gluster applications
Keywords:
Status: CLOSED DUPLICATE of bug 764655
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: GlusterFS Bugs list
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 02:16 UTC by Luis Pabón
Modified: 2016-11-08 22:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-18 05:59:50 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Luis Pabón 2014-07-22 02:16:52 UTC
Description of problem:
Looks like parts of cmockery was forgotten in glusterfs.spec.in:

# rpm -q -f  `which gluster`
glusterfs-cli-3.7dev-0.9.git5b8de97.fc20.x86_64
# ldd `which gluster`
	linux-vdso.so.1 =>  (0x00007ffff4dfe000)
	libglusterfs.so.0 => /lib64/libglusterfs.so.0 (0x00007fe034cc4000)
	libreadline.so.6 => /lib64/libreadline.so.6 (0x00007fe034a7d000)
	libncurses.so.5 => /lib64/libncurses.so.5 (0x00007fe034856000)
	libtinfo.so.5 => /lib64/libtinfo.so.5 (0x00007fe03462c000)
	libgfxdr.so.0 => /lib64/libgfxdr.so.0 (0x00007fe034414000)
	libgfrpc.so.0 => /lib64/libgfrpc.so.0 (0x00007fe0341f8000)
	libxml2.so.2 => /lib64/libxml2.so.2 (0x00007fe033e8f000)
	libz.so.1 => /lib64/libz.so.1 (0x00007fe033c79000)
	libm.so.6 => /lib64/libm.so.6 (0x00007fe033971000)
	libdl.so.2 => /lib64/libdl.so.2 (0x00007fe03376d000)
	libcmockery.so.0 => not found
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fe03354f000)
	libcrypto.so.10 => /lib64/libcrypto.so.10 (0x00007fe033168000)
	libc.so.6 => /lib64/libc.so.6 (0x00007fe032da9000)
	libcmockery.so.0 => not found
	libcmockery.so.0 => not found
	libcmockery.so.0 => not found
	liblzma.so.5 => /lib64/liblzma.so.5 (0x00007fe032b82000)
	/lib64/ld-linux-x86-64.so.2 (0x00007fe0351f1000)

Should I file a bug report or could someone on the fast-lane fix this?

/Anders
-- Anders Blomdell Email: anders.blomdell@control.lth.se 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2014-07-22 02:19:53 UTC
REVIEW: http://review.gluster.org/8340 (Cmockery is being linked against all applications) posted (#1) for review on master by Luis Pabon (lpabon@redhat.com)

Comment 2 Luis Pabón 2014-07-22 02:20:48 UTC
Simple issue in which when no default command is given to AC_CHECK_LIB it adds the library to LIBS.  This created an issue where it linked cmockery to all gluster applications.

Comment 3 Anand Avati 2014-07-24 04:25:11 UTC
REVIEW: http://review.gluster.org/8340 (Cmockery is being linked against all applications) posted (#2) for review on master by Emmanuel Dreyfus (manu@netbsd.org)

Comment 4 Niels de Vos 2014-09-18 05:59:50 UTC
This has been fixed with http://review.gluster.com/8365

*** This bug has been marked as a duplicate of bug 764655 ***


Note You need to log in before you can comment on or make changes to this bug.