Bug 1121828 - LibreOffice isn't installed in user's language
Summary: LibreOffice isn't installed in user's language
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-langpacks
Version: 21
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Parag Nemade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 03:06 UTC by Rafael Luik
Modified: 2015-09-10 09:49 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-10 09:49:40 UTC


Attachments (Terms of Use)
Anaconda logs (212.11 KB, application/gzip)
2014-07-23 21:22 UTC, Rafael Luik
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1182110 None None None Never

Internal Links: 1182110

Description Rafael Luik 2014-07-22 03:06:27 UTC
Run the Minimal CD boot media (Net-Install CD) and install Fedora in a language different than English (e.g. pt-BR).
Also applicable to the LiveCD.

Actual:
LibreOffice UI is in English when the installation finishes.
GNOME-Software doesn't show LibreOffice's UI languages. User has to deal with command-foo.

Expected:
The installer should fetch the user's interface language package and install it as default. Language is a great barrier for many users, command-foo is even greater...

Comment 1 David Shea 2014-07-22 14:25:33 UTC
Please attach the log files from the installation to this bug. They are copied to the installed system in /var/log/anaconda.

Comment 2 Rafael Luik 2014-07-23 21:22:47 UTC
Created attachment 920361 [details]
Anaconda logs

Done. It from a net-install.

Comment 3 David Shea 2014-07-24 21:24:27 UTC
Anaconda is writing the following to /etc/yum/pluginconf.d/langpacks.conf:

[main]
enabled=1

# What langpacks to install is all of:
# - any previously installed langpacks (stored in /var/lib/yum/plugins/langpacks)
# - any languages specified by $LANGUAGE
# - any langpacks listed in langpack_locales below
# -- if this variable is empty, the value of $LANG

#langpack_locales = ja_JP, zh_CN, mr_IN
# Added by Anaconda
langpack_locales = pt_BR.UTF-8


so it looks like the langpack plugin isn't pulling in the packages as requested.

Comment 4 Parag Nemade 2015-01-14 08:08:56 UTC
I have started testing of this. For fedora 20 HTTP installation, there is no langpacks.conf is created in /tmp directory, thus no changes in actual installed system's langpacks.conf file.

I see the fix that adds languages by anaconda in langpacks.conf is added in this commit https://git.fedorahosted.org/cgit/anaconda.git/commit/?id=432cebc36c98b29275a61b999b79fe3b3da41b1c

This is released in anaconda-22.6-1 release.

F20 released anaconda -> https://git.fedorahosted.org/cgit/anaconda.git/tree/pyanaconda/packaging/yumpayload.py?id=anaconda-20.25.16-1#n249

F21 released anaconda -> https://git.fedorahosted.org/cgit/anaconda.git/tree/pyanaconda/packaging/yumpayload.py?id=anaconda-21.48.22-1#n245

So, Fedora 20 will not work but Fedora 21 onwards should work. I will test F21 net installation as there is no Desktop DVD media/package tree available.

Comment 5 Parag Nemade 2015-01-14 13:18:47 UTC
Got the problem reproduced in Fedora 21. I almost forgot that this is because of incorrect sub-package name from libreoffice. We now have langpacks guidelines http://fedoraproject.org/wiki/Packaging:NamingGuidelines#Addon_Packages_.28langpacks.29

I will report separate bug to libreoffice to rename packages. The package should be renamed like this
libreoffice-langpack-pt-BR -> libreoffice-langpack-pt_BR

Comment 6 Parag Nemade 2015-09-10 09:49:40 UTC
As LibreOffice maintainers are not accepting to rename packages, I am closing this as WONTFIX by LibreOffice maintainers.


Note You need to log in before you can comment on or make changes to this bug.