Bug 1121870 - cli getspec asks volid instead of volname in usage
Summary: cli getspec asks volid instead of volname in usage
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 06:09 UTC by Atin Mukherjee
Modified: 2015-05-14 17:42 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 17:26:24 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2014-07-22 06:09:45 UTC
Description of problem:

cli getspec asks volid instead of volname

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:

Execute "gluster system getspec"

Actual results:
Usage: system:: getspec <VOLID>


Expected results:
Usage: system:: getspec <VOLNAME>


Additional info:

Comment 1 Anand Avati 2014-07-22 06:17:14 UTC
REVIEW: http://review.gluster.org/8342 (cli : glusterd getspec usage correction) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Anand Avati 2014-07-29 00:26:58 UTC
REVIEW: http://review.gluster.org/8342 (cli : glusterd getspec usage correction) posted (#2) for review on master by Krishnan Parthasarathi (kparthas@redhat.com)

Comment 3 Anand Avati 2014-07-30 06:53:34 UTC
REVIEW: http://review.gluster.org/8342 (cli : glusterd getspec usage correction) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 4 Anand Avati 2014-07-30 09:31:41 UTC
COMMIT: http://review.gluster.org/8342 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit 7d74792d225196585c24f8843bdba61a14c1c3d3
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Tue Jul 22 11:43:09 2014 +0530

    cli : glusterd getspec usage correction
    
    gluster system getspec asks to input volume-id instead of volume name
    
    Change-Id: I0baef9c937fc8948477aa65c8f98916b28c1e484
    BUG: 1121870
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/8342
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 5 Niels de Vos 2015-05-14 17:26:24 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:35:29 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:37:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Niels de Vos 2015-05-14 17:42:42 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.