Bug 1121919 - Can't install "yaf" with pecl
Summary: Can't install "yaf" with pecl
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Image
Version: 2.x
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Vojtech Vitek
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 07:09 UTC by Dumitru Ursu
Modified: 2015-05-15 00:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-22 16:00:30 UTC


Attachments (Terms of Use)

Description Dumitru Ursu 2014-07-22 07:09:30 UTC
Description of problem:
I can't install yaf framework for php, on the PHP 5.4 cartridge
on the PHP 5.3 cartridge won't install at all, due to missing PCRE library, and when provided manually, it will fail as the PHP 5.4 cartridge does.

Steps to Reproduce:
1. Crete an aplication.
2. use a PHP 5.4 cartridge
3. pecl install yaf


Actual results:
ERROR: failed to write /opt/rh/php54/root/usr/lib64/php/modules/yaf.so (copy(/opt/rh/php54/root/usr/lib64/php/modules/yaf.so): failed to open stream: Permission denied)

Expected results:
the yaf.so module should be written there.

Comment 1 Vojtech Vitek 2014-07-22 15:55:30 UTC
It's not possible to install custom PHP PECLs on OpenShift at the moment. You might want to:
1. Vote up https://trello.com/c/Ja9IcFIb Custom PECLs RFE
2. Vote up https://www.openshift.com/content/enable-custom-php-extensions Custom PECLs idea
3. Create a custom/downloadable cartridge (fork of https://github.com/openshift/origin-server/tree/master/cartridges/openshift-origin-cartridge-php) with built-in yaf.so library.

Unfortunately, there's no php-yaf CentOS/RHEL RPM available in the official/EPEL repositories at the moment (there's just one unofficial RPM built by Remi), so it's not easy for us to enable this PECL by default on OpenShift.


Note You need to log in before you can comment on or make changes to this bug.