Bug 1121945 - Error message needs to be rephrased when we create media without passing name
Summary: Error message needs to be rephrased when we create media without passing name
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Tomer Brisker
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard: Verified in Upstream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 08:22 UTC by Sachin Ghai
Modified: 2019-04-01 20:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:42:34 UTC


Attachments (Terms of Use)
error thrown by UI (45.71 KB, image/png)
2014-07-22 08:22 UTC, Sachin Ghai
no flags Details
error is rephrased (56.39 KB, image/png)
2015-09-01 12:57 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC
Foreman Issue Tracker 6714 None None None 2016-04-22 16:54:22 UTC

Description Sachin Ghai 2014-07-22 08:22:18 UTC
Created attachment 919827 [details]
error thrown by UI

Description of problem:
when we create install media without name, UI raised following error:

can't be blank and can't be blank or contain trailing white spaces.

I think this message needs to be rephrased. 
Reason: 

1. error message includes "can't be blank" twice. So one entry "can't be blank" is sufficient.

2. user can create media with trailing spaces so the "or contain trailing white spaces" is also not valid.



Version-Release number of selected component (if applicable):
sat6 GA snap1

How reproducible:
always

Steps to Reproduce:
1. create media without passing media name
2.
3.

Actual results:
UI raised following error:

can't be blank and can't be blank or contain trailing white spaces

Expected results:
I think message needs to be rephrased to just: can't be blank

Additional info:
Processing by MediaController#create as */*
  Parameters: {"utf8"=>"✓", "search"=>"", "authenticity_token"=>"VX+UKFuIgqWyHwxAdhnLIrzFLAmDgGh5qENjFuLnsso=", "medium"=>{"name"=>"", "path"=>"http://mirror.fakeos.org/vUABdE/$major.$minor/os/$arch", "media_path"=>"", "config_path"=>"", "image_path"=>"", "os_family"=>"", "location_ids"=>[""], "organization_ids"=>[""]}}
Failed to save: Name can't be blank, Name can't be blank or contain trailing white spaces.

Comment 2 Dominic Cleal 2014-07-22 08:28:54 UTC
Created redmine issue http://projects.theforeman.org/issues/6714 from this bug

Comment 3 Bryan Kearney 2015-01-27 11:02:41 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6714 has been closed

Comment 4 Sachin Ghai 2015-09-01 12:56:16 UTC
verified in upstream

foreman-proxy-1.10.0-0.develop.201508250705gitb446e0c.el6.noarch
rubygem-smart_proxy_discovery-1.0.2-1.el6.noarch
foreman-1.10.0-0.develop.201508241946git8658fa3.el6.noarch
foreman-release-1.10.0-0.develop.201508241946git8658fa3.el6.noarch
ruby193-rubygem-hammer_cli_import-0.10.21-3.el6.noarch
ruby193-rubygem-hammer_cli_foreman_docker-0.0.3-3.el6.noarch
ruby193-rubygem-hammer_cli-0.3.0-1.201508241209git174f507.el6.noarch
ruby193-rubygem-hammer_cli_foreman_tasks-0.0.7-2.el6.noarch
ruby193-rubygem-hammer_cli_foreman_bootdisk-0.1.3-2.el6.noarch
ruby193-rubygem-hammer_cli_katello-0.0.17-1.el6.noarch

Now on creating a media without name, UI throws proper error: can't be blank.

Comment 5 Sachin Ghai 2015-09-01 12:57:53 UTC
Created attachment 1069002 [details]
error is rephrased

Comment 8 errata-xmlrpc 2016-07-27 08:42:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.