Bug 1121950 - Package upload fails with larger rpms (30MB+) on 413 Request Entry Too Large
Summary: Package upload fails with larger rpms (30MB+) on 413 Request Entry Too Large
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: David Davis
QA Contact: sthirugn@redhat.com
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 08:30 UTC by Ivan Necas
Modified: 2015-05-05 19:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:28:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1162533 None None None Never

Description Ivan Necas 2014-07-22 08:30:49 UTC
Description of problem:
Package upload fails with larger rpms (30MB+) on 413 Request Entry Too Large

How reproducible:
Always

Steps to Reproduce:
1. hammer repository upload-package --id REPO_ID --path jre-7u45-linux-x64.rpm
2. fails with "413 Request Entry Too Large" error message in the hammer log

Expected results:
The package is uploaded successfully

Additional info:

Comment 2 Ivan Necas 2014-07-22 08:54:09 UTC
Changing the chunk size from 10MB so 2MB seemed to help here

Comment 4 David Davis 2014-08-06 12:37:59 UTC
I found out why the upload requests work in development mode:

https://github.com/Katello/katello-installer/blob/master/modules/katello/templates/etc/httpd/conf.d/05-foreman-ssl.d/katello.conf.erb#L19

We should probably sync this up with what Foreman's max request size.

Comment 5 David Davis 2014-08-06 13:04:23 UTC
Actually, that's in the rhsm api which wouldn't affect this.

Comment 6 Partha Aji 2014-08-06 13:17:05 UTC
Created redmine issue http://projects.theforeman.org/issues/6957 from this bug

Comment 8 Bryan Kearney 2014-08-06 16:03:37 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6957 has been closed
-------------
David Davis
Applied in changeset commit:hammer-cli-katello|26bbb0cd49e3a1ea2619d78948542702c4271ee5.

Comment 11 sthirugn@redhat.com 2014-09-04 20:10:34 UTC
I was able to upload a package of size 35 MB


hammer> repository upload-content --id 198 --organization-id=3 --path='/tmp/mongodb-2.4.6-2.el6sat.x86_64.rpm'
Successfully uploaded file 'mongodb-2.4.6-2.el6sat.x86_64.rpm'.

# ls -l mongodb*
-rw-r--r--. 1 root    root    36567716 Sep  4 16:04 mongodb-2.4.6-2.el6sat.x86_64.rpm


Version Tested:
GA Snap 7 - Satellite-6.0.4-RHEL-6-20140829.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.23-1.el6_5.noarch
* candlepin-common-1.0.1-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.23-1.el6_5.noarch
* candlepin-tomcat6-0.9.23-1.el6_5.noarch
* elasticsearch-0.90.10-6.el6sat.noarch
* foreman-1.6.0.42-1.el6sat.noarch
* foreman-compute-1.6.0.42-1.el6sat.noarch
* foreman-gce-1.6.0.42-1.el6sat.noarch
* foreman-libvirt-1.6.0.42-1.el6sat.noarch
* foreman-ovirt-1.6.0.42-1.el6sat.noarch
* foreman-postgresql-1.6.0.42-1.el6sat.noarch
* foreman-proxy-1.6.0.30-1.el6sat.noarch
* foreman-selinux-1.6.0.14-1.el6sat.noarch
* foreman-vmware-1.6.0.42-1.el6sat.noarch
* katello-1.5.0-30.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.62-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* openldap-devel-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-4.el6sat.noarch
* pulp-nodes-common-2.4.1-0.5.rc1.el6sat.noarch
* pulp-nodes-parent-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-tools-2.4.1-0.5.rc1.el6sat.noarch
* pulp-rpm-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-selinux-2.4.1-0.5.rc1.el6sat.noarch
* pulp-server-2.4.1-0.5.rc1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch

Comment 12 Bryan Kearney 2014-09-11 12:28:51 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.