Bug 1121970 - File conflict between MySQL-zrm-3.0-3.el6.noarch and MySQL-zrm-client-3.0-1.noarch
Summary: File conflict between MySQL-zrm-3.0-3.el6.noarch and MySQL-zrm-client-3.0-1.n...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: MySQL-zrm
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 09:08 UTC by Arnau
Modified: 2014-07-23 08:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-23 04:44:22 UTC


Attachments (Terms of Use)

Description Arnau 2014-07-22 09:08:47 UTC
Description of problem:

MySQL-zrm cannot be upgraded in SL 6.3 because there is a file conflict between two versions.

Version-Release number of selected component (if applicable):

Installed version: MySQL-zrm-client-3.0-1.noarch
Installable candidate: MySQL-zrm-3.0-3.el6.noarch

How reproducible:

Install MySQL-zrm-client-3.0-1.noarch and upgrade to MySQL-zrm-3.0-3.el6.noarch

Actual results:


Transaction Check Error:
  file /etc/xinetd.d/mysql-zrm-socket-server from install of MySQL-zrm-3.0-3.el6.noarch conflicts with file from package MySQL-zrm-client-3.0-1.noarch
  file /usr/share/mysql-zrm/plugins/lvm-snapshot.pl from install of MySQL-zrm-3.0-3.el6.noarch conflicts with file from package MySQL-zrm-client-3.0-1.noarch
  file /usr/share/mysql-zrm/plugins/socket-copy.pl from install of MySQL-zrm-3.0-3.el6.noarch conflicts with file from package MySQL-zrm-client-3.0-1.noarch
  file /usr/share/mysql-zrm/plugins/socket-server.pl from install of MySQL-zrm-3.0-3.el6.noarch conflicts with file from package MySQL-zrm-client-3.0-1.noarch
  file /usr/share/mysql-zrm/plugins/ssh-copy.pl from install of MySQL-zrm-3.0-3.el6.noarch conflicts with file from package MySQL-zrm-client-3.0-1.noarch
  file /usr/share/mysql-zrm/plugins/zfs-snapshot.pl from install of MySQL-zrm-3.0-3.el6.noarch conflicts with file from package MySQL-zrm-client-3.0-1.noarch


Expected results:

newer version installed.

Additional info:

Comment 1 Orion Poplawski 2014-07-22 13:13:57 UTC
Hmm, I never made an attempt to be compatible with the upstream packages.   I'll take a look though.

Comment 2 Orion Poplawski 2014-07-23 04:44:22 UTC
The upstream rpms do not have a clean separation between the main and -client sub-packages, so I'm not going to attempt to reproduce it or support upgrading from it.

Comment 3 Arnau 2014-07-23 08:44:53 UTC
Thanks for checking. I'll install EPEL version from scratch.


Note You need to log in before you can comment on or make changes to this bug.