Bug 1121989 - gvfs-info shows different time stamp then ls
Summary: gvfs-info shows different time stamp then ls
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gvfs
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Ondrej Holy
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 09:52 UTC by Ladislav Kolacek
Modified: 2014-09-16 12:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-16 12:57:53 UTC


Attachments (Terms of Use)

Description Ladislav Kolacek 2014-07-22 09:52:01 UTC
Description of problem:


Version-Release number of selected component (if applicable):
gvfs-1.4.3-16.el6_5

How reproducible:
100%

Steps to Reproduce:
    Make sure you have gvfs installed.

    Prepare a testing file:

    touch new

    Run:

    $ gvfs-info new | grep time::modified
      time::modified: 1294241458

    Run

     gvfs-set-attribute new time::modified -t uint64 13

    Run

    gvfs-info new | grep time::modified

Actual results:
ls -lh new
-rw-rw-r--. 1 test test 7 Dec 31  1969 new

Expected results:
ls -lh new
-rw-rw-r--. 1 tpelka tpelka 0 Jan  1  1970 new

Additional info:

Comment 1 Ondrej Holy 2014-07-30 16:46:23 UTC
Are you testing it on a local filesystem?

It works for me correctly with referenced gvfs version and recent glib2:
gvfs-1.4.3-16.el6_5
glib2-2.28.8-1.el6

(This could be bug in glib2, because gvfs is wrapper for glib2 in this case.)

Comment 2 Ladislav Kolacek 2014-07-31 10:27:54 UTC
I am testing on local filesystem.

I upgraded glib2 to version glib2-2.28.8-1.el6 as well and I got the same results: "-rw-rw-r--. 1 test test 7 Dec 31  1969 new"
on both gvfs versions: gvfs-1.4.3-16.el6_5 and gvfs-1.4.3-18.el6.

If you want to I could give you access to my testing VM.

Comment 3 Ondrej Holy 2014-08-07 12:02:18 UTC
(In reply to Ladislav Kolacek from comment #2)

Are you able to reproduce it with fresh install or have you modified it somehow? 

> If you want to I could give you access to my testing VM.

Please do so.

Comment 4 Ondrej Holy 2014-08-14 11:34:40 UTC
Thanks for the access, some results from the testing VM:

Integer values are same:
$ gvfs-set-attribute new time::modified -t uint64 13
$ gvfs-info new | grep time::modified
  time::modified: 13
$ stat -c %Y new
13

Timezone is set to -5:
$ ls -l --time-style=full-iso new
-rw-rw-r--. 1 test test 0 1969-12-31 19:00:13.000000000 -0500 new

So the time is correct, isn't it?


Note You need to log in before you can comment on or make changes to this bug.