Bug 1122001 - Confusing message after register with consumer ID without --auto-attach option
Summary: Confusing message after register with consumer ID without --auto-attach option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: pre-dev-freeze
: 7.1
Assignee: Chris "Ceiu" Rog
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel71
TreeView+ depends on / blocked
 
Reported: 2014-07-22 10:29 UTC by qianzhan
Modified: 2015-03-05 13:17 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 13:17:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0502 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2015-03-05 16:20:39 UTC

Description qianzhan 2014-07-22 10:29:49 UTC
Description of problem:
Confusing message after register with consumer ID without --auto-attach option

Version-Release number of selected component (if applicable):
candlepin-0.9.6.4-1.el6sam.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.9.6.4-1.el6sam.noarch
candlepin-tomcat6-0.9.6.4-1.el6sam.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.3.1-1.el6sam.noarch
katello-cli-common-1.4.3.1-1.el6sam.noarch
katello-common-1.4.3.26-1.el6sam_splice.noarch
katello-configure-1.4.5-1.el6sam.noarch
katello-glue-candlepin-1.4.3.26-1.el6sam_splice.noarch
katello-glue-elasticsearch-1.4.3.26-1.el6sam_splice.noarch
katello-headpin-1.4.3.26-1.el6sam_splice.noarch
katello-headpin-all-1.4.3.26-1.el6sam_splice.noarch
katello-selinux-1.4.4-2.el6sat.noarch
ruby193-rubygem-katello-redhat-access-engine-0.0.1-1.el6sam.noarch
thumbslug-0.0.40-1.el6sam.noarch
thumbslug-selinux-0.0.40-1.el6sam.noarch
subscription-manager: 1.12.4-1.el6
python-rhsm: 1.12.4-1.el6

How reproducible:
Always

Steps to Reproduce:
1. Register a client to SAM and record the consumer ID:

[root@dhcp-14-238 ~]# subscription-manager identity
This system is not yet registered. Try 'subscription-manager register --help' for more information.

[root@dhcp-14-238 ~]# subscription-manager register
Username: admin
Password: 
The system has been registered with ID: 8ceae445-b222-4084-81ce-4591b0d9840c 

2. Remove the consumer certs and re-register with the recorded consumer ID without auto-attach option:

[root@dhcp-14-238 ~]# rm -f /etc/pki/consumer/*
[root@dhcp-14-238 ~]# ls /etc/pki/consumer/

[root@dhcp-14-238 ~]# subscription-manager register --consumerid=8ceae445-b222-4084-81ce-4591b0d9840c
Username: admin
Password: 
The system has been registered with ID: 8ceae445-b222-4084-81ce-4591b0d9840c 
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Not Subscribed

Unable to find available subscriptions for all your installed products.

3. Remove the consumer certs and re-register with the recorded consumer ID and auto-attach option:

[root@dhcp-14-238 ~]# rm -f /etc/pki/consumer/*
[root@dhcp-14-238 ~]# subscription-manager register --consumerid=8ceae445-b222-4084-81ce-4591b0d9840c --auto-attach
Username: admin
Password: 
The system has been registered with ID: 8ceae445-b222-4084-81ce-4591b0d9840c 
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed


Actual results:
As step 2, when register the client to SAM with a specified consumer ID without auto-attach, prompt a notice: "Unable to find available subscriptions for all your installed products."
while in step 3 with auto-attach, an available subscription can be found for the installed products.

Expected results:

Is "Installed Product Current Status:" part necessary in step 2 ? 
If so, why is "Unable to find available subscriptions for all your installed products." displayed when an available subscription can be found?
If not, please remove "Installed Product Current Status:" and its explanation for the status.



Additional info:

Comment 1 Bryan Kearney 2014-09-12 17:43:05 UTC
This is really a subscription manager issue.

Comment 3 Chris "Ceiu" Rog 2014-10-01 17:57:16 UTC
commit 6f82c03f05804dcc28eb66d8126453f73c250488
Author: Chris Rog <crog@redhat.com>
Date:   Tue Sep 30 11:08:06 2014 -0400

    1122001: Reg with --consumerid no longer checks subs
    
    Registration with the --consumerid specified, but without using the
    --autosubscribe or --auto-attach options no longer checks the
    subscription status.
    
    This also addresses bug 1145835 in which the registration was erroneously
    reporting a failure in the same case.

Comment 5 qianzhan 2014-11-04 03:32:50 UTC
Version-Release number of selected component (if applicable):
subscription-manager: 1.13.6-1.el7
python-rhsm: 1.13.6-1.el7

Verification:
[root@dhcp-129-187 ~]# subscription-manager identity
system identity: 2d96f759-550e-4a0d-97be-fef87c77d262
name: dhcp-129-187.nay.redhat.com
org name: ACME_Corporation
org ID: ACME_Corporation
[root@dhcp-129-187 ~]# rm -f /etc/pki/consumer/*
[root@dhcp-129-187 ~]# ls /etc/pki/consumer/
[root@dhcp-129-187 ~]# subscription-manager register --consumerid=2d96f759-550e-4a0d-97be-fef87c77d262
Username: admin
Password: 
The system has been registered with ID: 2d96f759-550e-4a0d-97be-fef87c77d262 

[root@dhcp-129-187 ~]# rm -f /etc/pki/consumer/*
[root@dhcp-129-187 ~]# subscription-manager register --consumerid=2d96f759-550e-4a0d-97be-fef87c77d262 --auto-attach
Username: admin
Password: 
The system has been registered with ID: 2d96f759-550e-4a0d-97be-fef87c77d262 

Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed

This bug is verified, but I met an issue that can not move it to ON_QA. Ask gxing to help me.

Comment 6 qianzhan 2014-11-04 03:35:10 UTC
(In reply to qianzhan from comment #5)
> Version-Release number of selected component (if applicable):
> subscription-manager: 1.13.6-1.el7
> python-rhsm: 1.13.6-1.el7
> 
> This bug is verified, but I met an issue that can not move it to ON_QA. Ask
> gxing to help me.

Oh sorry , I mean I can not move it to VERIFIED...

Comment 8 errata-xmlrpc 2015-03-05 13:17:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0502.html


Note You need to log in before you can comment on or make changes to this bug.