Bug 1122046 - Undo previewed snapshot doesn't work
Summary: Undo previewed snapshot doesn't work
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Daniel Erez
QA Contact: Pavel Stehlik
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 12:32 UTC by Raz Tamir
Modified: 2016-02-10 16:45 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 12:40:43 UTC
oVirt Team: Storage


Attachments (Terms of Use)
vdsm and engine logs (1.46 MB, application/x-gzip)
2014-07-22 19:58 UTC, Raz Tamir
no flags Details

Description Raz Tamir 2014-07-22 12:32:40 UTC
Description of problem:
After previewing snapshot, all the I/O changes will be write to a temporary volume.
In case of undo the previewed snapshot, this temporary volume removed and all the write operations will be on the Active volume.
In this case all the changes that occurs between the preview and the undo, will be ignored.
The flow is as follow:
* write file to disk
* take snapshot
* preview the snapshot
* delete the file
* undo the previewed snapshot

--> The file should be visible on the vm's disk. 

** Also NICs that removed in time that the vm was in preview mode weren't restored after undo.


Version-Release number of selected component (if applicable):
ovirt-engine-3.5.0-0.0.master.20140715172116.git4687dc1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
explained above

Expected results:
All the files that were created/removed in preview mode should be removed/restored after undo

Additional info:
Nothing in engine/vdsm logs

Comment 1 Allon Mureinik 2014-07-22 15:00:38 UTC
Raz, can you attach engine and VDSM logs please?

Comment 2 Raz Tamir 2014-07-22 19:58:59 UTC
Created attachment 920041 [details]
vdsm and engine logs

Sure - logs attached

Comment 3 Daniel Erez 2014-07-23 17:17:27 UTC
Tried to reproduce the described scenario on latest build - works fine.
@Raz - Which vdsm version are you using? Is it reproducible in previous build as well? Is it 100% reproducible on both file and block domains?

Comment 4 Raz Tamir 2014-07-24 12:03:04 UTC
* vdsm - vdsm-4.16.0-27.git00146ed.el6.x86_64
* Tried to reproduce on 3.4.1 and it works fine (Undo works)
* Tried only on block

Comment 5 Daniel Erez 2014-08-06 12:40:43 UTC
(In reply to ratamir from comment #4)
> * vdsm - vdsm-4.16.0-27.git00146ed.el6.x86_64
> * Tried to reproduce on 3.4.1 and it works fine (Undo works)
> * Tried only on block

Thanks Raz. Closing as WORKSFORME, please reopen if reproduced.


Note You need to log in before you can comment on or make changes to this bug.