Bug 1122052 - make: *** No rule to make target `naemon.if', needed by `tmp/all_interfaces.conf'. Stop.
Summary: make: *** No rule to make target `naemon.if', needed by `tmp/all_interfaces.c...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 12:49 UTC by Stef Walter
Modified: 2014-09-10 02:45 UTC (History)
1 user (show)

Fixed In Version: selinux-policy-3.13.1-78.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-10 02:45:55 UTC


Attachments (Terms of Use)

Description Stef Walter 2014-07-22 12:49:54 UTC
Description of problem:

Can't build the selinux-policy-targetted using "fedpkg local"

...
python -E support/genclassperms.py policy/flask/access_vectors policy/flask/security_classes > tmp/generated_definitions.conf
test -f policy/booleans.conf && gawk -f support/set_bools_tuns.awk policy/booleans.conf >> tmp/generated_definitions.conf || true
make: *** No rule to make target `naemon.if', needed by `tmp/all_interfaces.conf'.  Stop.
error: Bad exit status from /var/tmp/rpm-tmp.DQB9gc (%install)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.DQB9gc (%install)
Could not execute local: Non zero exit

Version-Release number of selected component (if applicable):

On origin/f21 branch:

commit cccaf8f6468931e6b0093ceb084698d286b88796
Author: Miroslav Grepl <mgrepl@redhat.com>
Date:   Tue May 20 07:59:07 2014 +0200
...

How reproducible:

At present with the above commit, every time.

Steps to Reproduce:
1. git fetch origin
2. git checkout f21
3. fedpkg local

Comment 1 Miroslav Grepl 2014-07-23 07:55:22 UTC
$ fedpkg clone selinux-policy;cd selinux-policy;git checkout f21;fedpkg local

works for me.

Comment 2 Stef Walter 2014-07-23 08:49:41 UTC
Odd. Perhaps it's due to an installed build dependency?

I have:

Linux stef.thewalter.lan 3.16.0-0.rc6.git0.1.fc21.1.x86_64 #1 SMP Mon Jul 21 21:50:04 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

policycoreutils-devel-2.3-6.fc21.x86_64
sectool-0.9.5-13.fc21.x86_64

Tried blowing away the cloning again with the same result. Also:

$ find . -name 'naemon.*'
... no output

Comment 3 Miroslav Grepl 2014-07-23 09:02:26 UTC
I see it now. 

Lukas,
could you fix it? It causes your latest commit.

Comment 4 Lukas Vrabec 2014-07-23 09:08:21 UTC
Yes, I'm working on it now.

Comment 5 Lukas Vrabec 2014-07-23 11:23:40 UTC
I fix it by add new patch to selinux-policy repo.
I also going to make new build for F21.

commit d2ba2351bd6fa7c54e0f38ad711dae4c8b5ab819
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Wed Jul 23 11:17:04 2014 +0200

    Add actual patch with naemon policy


Thank you for report!

Comment 6 Fedora Update System 2014-08-28 14:10:55 UTC
selinux-policy-3.13.1-77.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/selinux-policy-3.13.1-77.fc21

Comment 7 Fedora Update System 2014-08-28 16:42:39 UTC
Package selinux-policy-3.13.1-77.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.13.1-77.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9873/selinux-policy-3.13.1-77.fc21
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2014-09-02 19:29:39 UTC
selinux-policy-3.13.1-78.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/selinux-policy-3.13.1-78.fc21

Comment 9 Fedora Update System 2014-09-10 02:45:55 UTC
selinux-policy-3.13.1-78.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.