Bug 1122059 - The warning message pop up 8 times repeatly when there is no enough free space to allocate for virt-install
Summary: The warning message pop up 8 times repeatly when there is no enough free spac...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Giuseppe Scrivano
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 851412
Blocks: 1034685
TreeView+ depends on / blocked
 
Reported: 2014-07-22 13:03 UTC by Giuseppe Scrivano
Modified: 2015-03-05 10:06 UTC (History)
9 users (show)

Fixed In Version: virt-manager-1.1.0-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of: 851412
Environment:
Last Closed: 2015-03-05 10:06:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0427 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2015-03-05 14:38:46 UTC

Comment 2 Cui Lei 2014-09-09 09:29:06 UTC
I can reproduce this issue with:
virt-manager-0.10.0-20.el7.noarch
virt-install-0.10.0-20.el7.noarch

The warning message repeat 8 times:

# virt-install -n vm1 -r 1024 --disk path=vm1.img,size=100000000 -c /dev/cdrom
WARNING  The requested volume capacity will exceed the available pool space when the volume is fully allocated. (102400000000 M requested capacity > 3359 M available)
WARNING  The requested volume capacity will exceed the available pool space when the volume is fully allocated. (102400000000 M requested capacity > 3359 M available)
WARNING  The requested volume capacity will exceed the available pool space when the volume is fully allocated. (102400000000 M requested capacity > 3359 M available)
WARNING  The requested volume capacity will exceed the available pool space when the volume is fully allocated. (102400000000 M requested capacity > 3359 M available)
WARNING  The requested volume capacity will exceed the available pool space when the volume is fully allocated. (102400000000 M requested capacity > 3359 M available)
WARNING  The requested volume capacity will exceed the available pool space when the volume is fully allocated. (102400000000 M requested capacity > 3359 M available)
WARNING  The requested volume capacity will exceed the available pool space when the volume is fully allocated. (102400000000 M requested capacity > 3359 M available)
WARNING  The requested volume capacity will exceed the available pool space when the volume is fully allocated. (102400000000 M requested capacity > 3359 M available)
WARNING  The requested volume capacity will exceed the available pool space when the volume is fully allocated. (102400000000 M requested capacity > 3359 M available)
ERROR    The requested volume capacity will exceed the available pool space when the volume is fully allocated. (102400000000 M requested capacity > 3359 M available) (Use --force to override)

Verify this issue with:
virt-manager-1.1.0-1.el7

# virt-install -n vm1 -r 1024 --disk path=vm1.img,size=100000000 -c /dev/cdrom
WARNING  The requested volume capacity will exceed the available pool space when the volume is fully allocated. (102400000000 M requested capacity > 3383 M available)
ERROR    Error: --disk path=vm1.img,size=100000000: There is not enough free space on the storage pool to create the volume. (102400000000 M requested allocation > 3383 M available)

Which display normal.

So change the status from 'ON_QA' to 'VERIFIED'

Comment 4 errata-xmlrpc 2015-03-05 10:06:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0427.html


Note You need to log in before you can comment on or make changes to this bug.