Bug 1122081 - BTRFVolumeDevice does not fill mountpoint property
Summary: BTRFVolumeDevice does not fill mountpoint property
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: mulhern
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F21AlphaFreezeException
TreeView+ depends on / blocked
 
Reported: 2014-07-22 13:44 UTC by Jan Safranek
Modified: 2014-12-05 01:54 UTC (History)
9 users (show)

Fixed In Version: python-blivet-0.61.1-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-05 01:54:32 UTC


Attachments (Terms of Use)

Description Jan Safranek 2014-07-22 13:44:37 UTC
I have a btrfs volume with two devices mounted on /mnt/test:
# mkfs.btrfs /dev/vdb2 /dev/vdb3
# mount /dev/vdb2 /mnt/test

In python-blivet 0.54, following code prints mountpoint of /dev/vdb3:

    b = blivet.Blivet()
    b.reset()

    vdb3 = b.devicetree.getDeviceByName('vdb3')
    # we know that vdb3 contains btrfs...
    children  = b.deviceDeps(vdb3)
    c = children[0]
    print c.format.mountpoint
/mnt/test

With python-blivet-0.61, it prints None. This is API change and it breaks OpenLMI.

Comment 1 David Lehman 2014-08-29 18:45:04 UTC
This was changed unintentionally by commit 822d92457e36768b. I expect we'll be reverting that commit to fix this bug.

Comment 2 mulhern 2014-09-02 20:41:23 UTC
Note that fix is acked and ready to go.

Comment 3 mulhern 2014-09-02 20:49:23 UTC
I found out the standard process for proposing a blocker, which doesn't just involve setting it to block the blocker bug, so I'll try that.

Comment 4 Fedora Blocker Bugs Application 2014-09-02 20:54:41 UTC
Proposed as a Blocker for 21-alpha by Fedora user mulhern using the blocker tracking app because:

 The change fixes a regression introduced in commit 822d92457e36768b9daa6a3ec689e494e9ba07df.  It affects openlmi btrfs related actions. The fix is simple, acked, and ready to go.

Comment 5 Adam Williamson 2014-09-03 12:56:27 UTC
This sounds more like freeze exception than blocker stuff to me - in the Fedora process we have a specific status for 'things that we want to put through the freeze, but don't actually break the release criteria':

https://fedoraproject.org/wiki/QA:SOP_freeze_exception_bug_process

We can certainly consider this as a release blocker, but the criteria for Alpha storage are fairly minimal, and my guess is it'd be rejected:

https://fedoraproject.org/wiki/Fedora_21_Alpha_Release_Criteria

so unless you actually think we need to *block* the release on this, as opposed to just wanting to pull the fix through the freeze, we could go for 'freeze exception' not blocker status.

Comment 6 Fedora Blocker Bugs Application 2014-09-03 13:10:15 UTC
Proposed as a Freeze Exception for 21-alpha by Fedora user mulhern using the blocker tracking app because:

 The change fixes a regression introduced in commit 822d92457e36768b9daa6a3ec689e494e9ba07df.  It affects openlmi btrfs related actions. The fix is simple, acked, and ready to go.

Comment 7 Adam Williamson 2014-09-03 15:00:06 UTC
Were you able to convert the bug from a blocker to an FE using the blocker reporting webapp? If not, we should probably look at that...

Comment 8 mulhern 2014-09-03 15:47:49 UTC
No, I was not able to figure out conversion, I figured that the propose link would do the swap, i.e., if proposed as freeze would remove from proposed blockers, but that did not work. Now it is both a blocker and a freeze, please treat as freeze.

Comment 9 Adam Williamson 2014-09-03 16:50:14 UTC
https://fedorahosted.org/fedora-qa/ticket/453

Comment 10 Adam Williamson 2014-09-03 17:06:59 UTC
https://phab.qadevel.cloud.fedoraproject.org/T320 ...

Comment 11 Mike Ruckman 2014-09-03 17:31:02 UTC
Discussed in 2014-09-03 Blocker Review Meeting. Voted as an Accepted Blocker - we will accept a fix if done before release.

Comment 12 Adam Williamson 2014-09-04 03:59:32 UTC
s/Accepted Blocker/accepted freeze exception/

Comment 13 Fedora Update System 2014-09-04 18:46:15 UTC
python-blivet-0.61.1-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-blivet-0.61.1-1.fc21

Comment 14 Fedora Update System 2014-09-06 00:59:28 UTC
Package python-blivet-0.61.1-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.61.1-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-10190/python-blivet-0.61.1-1.fc21
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2014-09-17 23:46:28 UTC
python-blivet-0.61.2-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-blivet-0.61.2-2.fc21

Comment 16 Adam Williamson 2014-12-05 01:54:32 UTC
This was clearly resolved long ago.


Note You need to log in before you can comment on or make changes to this bug.