Bug 1122087 - Placing configuration file in /etc/tmpfiles.d/
Summary: Placing configuration file in /etc/tmpfiles.d/
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libstoragemgmt
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Tony Asleson
QA Contact: Bruno Goncalves
URL:
Whiteboard:
: 1180980 (view as bug list)
Depends On:
Blocks: 1122117
TreeView+ depends on / blocked
 
Reported: 2014-07-22 14:03 UTC by Tony Asleson
Modified: 2015-03-05 13:14 UTC (History)
2 users (show)

Fixed In Version: libstoragemgmt-1.0.0-3.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1122117 (view as bug list)
Environment:
Last Closed: 2015-03-05 13:14:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0529 normal SHIPPED_LIVE LibStorageMgmt bug fix and enhancement update 2015-03-05 16:20:12 UTC

Description Tony Asleson 2014-07-22 14:03:21 UTC
Description of problem:

Libstoragemgmt is placing a configuration file in /etc/tmpfiles.d.

"Packages should install their configuration files in /usr/lib/tmpfiles.d. Files in /etc/tmpfiles.d are reserved for the local administrator, who may use this logic to override the configuration files installed by vendor packages"

Need to update rpm spec file to place file in correct directory.

Comment 3 Bruno Goncalves 2014-10-06 12:04:01 UTC
Verified with libstoragemgmt-1.0.0-3.el7.


# rpm -q libstoragemgmt
libstoragemgmt-0.0.24-4.el7.x86_64

# ls /etc/tmpfiles.d/
libstoragemgmt.conf  screen.conf  tuned.conf


# ls /usr/lib/tmpfiles.d/
abrt.conf       cups.conf     initscripts.conf  libselinux.conf  pam.conf  rpm.conf        selinux-policy.conf        svnserve.conf  systemd-nologin.conf  x11.conf
beakerlib.conf  cups-lp.conf  legacy.conf       lvm2.conf        ppp.conf  saslauthd.conf  subscription-manager.conf  systemd.conf   tmp.conf

-----------
# rpm -q libstoragemgmt
libstoragemgmt-1.0.0-3.el7.x86_64

# ls /etc/tmpfiles.d/
screen.conf  tuned.conf

# ls /usr/lib/tmpfiles.d/
abrt.conf       cups.conf     initscripts.conf  libselinux.conf      lvm2.conf  ppp.conf  saslauthd.conf       subscription-manager.conf  systemd.conf          tmp.conf
beakerlib.conf  cups-lp.conf  legacy.conf       libstoragemgmt.conf  pam.conf   rpm.conf  selinux-policy.conf  svnserve.conf              systemd-nologin.conf  x11.conf

Comment 4 Tony Asleson 2015-01-12 15:12:54 UTC
*** Bug 1180980 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2015-03-05 13:14:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0529.html


Note You need to log in before you can comment on or make changes to this bug.