Bug 1122099 - Unable to delete users
Summary: Unable to delete users
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: David Davis
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 14:27 UTC by Matej Kollar
Modified: 2019-09-25 20:48 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:24:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6606 None None None 2016-04-22 15:14:15 UTC

Description Matej Kollar 2014-07-22 14:27:18 UTC
Description of problem: Trying to delete user (even non admin) I get reponce (manifesting itself in WebUI via red bubble) "Can't delete tha last admin account". Production.log:

Processing by UsersController#destroy as HTML
  Parameters: {"authenticity_token"=>"q9nXX+Vr5C6f38gXvKidlYvtgUHkpBZ+3CNg2P9J/X4=", "id"=>"6-tester"}
Unable to delete the last admin account
Failed to save: Can't delete the last admin account
Redirected to https://example.com/users
Completed 302 Found in 57ms (ActiveRecord: 9.1ms)
Processing by UsersController#index as HTML
  Rendered users/index.html.erb within layouts/application (27.0ms)
  Rendered common/_searchbar.html.erb (3.8ms)
  Rendered home/_user_dropdown.html.erb (1.1ms)
Read fragment views/tabs_and_title_records-3 (0.2ms)
  Rendered home/_topbar.html.erb (2.0ms)
  Rendered layouts/base.html.erb (3.8ms)
Completed 200 OK in 58ms (Views: 34.6ms | ActiveRecord: 5.6ms)
Processing by UsersController#index as HTML
  Rendered users/index.html.erb within layouts/application (22.1ms)
  Rendered common/_searchbar.html.erb (2.9ms)
  Rendered home/_user_dropdown.html.erb (1.1ms)
Read fragment views/tabs_and_title_records-3 (0.2ms)
  Rendered home/_topbar.html.erb (2.0ms)
  Rendered layouts/base.html.erb (3.4ms)
Completed 200 OK in 52ms (Views: 28.4ms | ActiveRecord: 5.3ms)

How reproducible: always/deterministic

Steps to Reproduce:
  1. create user
  2. try deleting user

Actual results:
  "Can't delete tha last admin account",
  user is not delted

Expected results:
  user is deleted

Comment 2 RHEL Product and Program Management 2014-07-22 14:54:04 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Dominic Cleal 2014-07-24 13:07:07 UTC
Connecting redmine issue http://projects.theforeman.org/issues/6606 from this bug

Comment 8 Corey Welton 2014-07-30 18:13:47 UTC
Verified in Satellite-6.0.4-RHEL-6-20140723.0

Comment 10 Bryan Kearney 2014-09-11 12:24:04 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.