Bug 112212 - Losing network kills local users
Summary: Losing network kills local users
Status: CLOSED DUPLICATE of bug 55193
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: util-linux   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-16 10:36 UTC by Nicolas Mailhot
Modified: 2006-02-21 19:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full non-network /var/log/messages boot log (24.77 KB, text/plain)
2004-01-16 09:25 UTC, Nicolas Mailhot
no flags Details

Description Nicolas Mailhot 2003-12-16 10:36:50 UTC
Yesterday's rawhide sync killed dhclient here and as a result I lost
the network. Since all users are in ldap+krb+nfs home this means they
could not be used.

However root is *not* a network user, it's a local one exactly for
this reason (ie fixups when network is AWOL), and it saved the day in
the past.

This time the root account was dead. I had to restart in single mode,
and switch the eth entry to fixed address, then restart network before
root was allowed to log in again.

Comment 1 Nicolas Mailhot 2003-12-16 10:37:49 UTC
util-linux-2.11y-35.sel

Comment 2 Elliot Lee 2004-01-15 19:31:16 UTC
Dan, would you look into this? I suspect it has something to do with
the SELinux patches.

Comment 3 Daniel Walsh 2004-01-15 19:48:25 UTC
Maybe, but SELinux should be turned off if they are not running a 2.6
kernel with a loaded policy.  What is being reported in /var/log/messages?

Comment 4 Nicolas Mailhot 2004-01-15 20:02:58 UTC
Well, obviously I didn't test killing the box every day since I filled
this bug;). I'll try to reproduce it tomorrow when I have access to
the system.

Comment 5 Nicolas Mailhot 2004-01-16 09:25:12 UTC
Created attachment 97049 [details]
Full non-network /var/log/messages boot log

Comment 6 Nicolas Mailhot 2004-01-16 09:27:02 UTC
I reproduced it today after a new rawhide sync (since dhcp was fixed I
yanked the network wire). Attached is the full /var/log/messages for
this boot. Local root login was attempted thrice, but does not even
seem to be registered in the logs.

Comment 7 Matthew Miller 2004-03-30 14:57:55 UTC
I don't think this is SE Linux. I think it's the long-standing problem
with the pam auth file. In other words, this is a dup of bug #55193,
from 2001-10-26.

*** This bug has been marked as a duplicate of 55193 ***

Comment 8 Red Hat Bugzilla 2006-02-21 19:00:26 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.