Bug 1122157 - [patch] don't add timestamps to .elc files
Summary: [patch] don't add timestamps to .elc files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Hracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 16:31 UTC by Benedikt Morbach
Modified: 2014-08-31 23:21 UTC (History)
4 users (show)

Fixed In Version: emacs-24.3-22.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-15 02:52:06 UTC


Attachments (Terms of Use)
upstream patch (without NEWS and ChangeLog changes) (1.27 KB, patch)
2014-07-22 16:31 UTC, Benedikt Morbach
no flags Details | Diff
specfile patch (3.37 KB, patch)
2014-07-22 16:32 UTC, Benedikt Morbach
no flags Details | Diff

Description Benedikt Morbach 2014-07-22 16:31:40 UTC
Created attachment 919960 [details]
upstream patch (without NEWS and ChangeLog changes)

Description of problem:
emacs adds timestamps, user and host information to .elc files when compiling them. This is annoying because building the same file twice gives different results for pointless reasons.

Upstream agrees that that is stupid and changed it.

I'm currently working on reproducible builds for Fedora and this blocks anything emacs-y from being reproducible.

As the patch just removes a few lines, could we add it until they roll a release?

I'll attach the upstream patch and a patch against the Fedora emacs repo and let you pick :)

Comment 1 Benedikt Morbach 2014-07-22 16:32:24 UTC
Created attachment 919961 [details]
specfile patch

Comment 3 Fedora Update System 2014-07-29 12:24:10 UTC
emacs-24.3-18.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/emacs-24.3-18.fc20

Comment 4 Fedora Update System 2014-07-30 06:59:40 UTC
Package emacs-24.3-18.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing emacs-24.3-18.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8989/emacs-24.3-18.fc20
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-08-01 13:41:45 UTC
emacs-24.3-19.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/emacs-24.3-19.fc20

Comment 6 Fedora Update System 2014-08-04 13:59:43 UTC
emacs-24.3-21.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/emacs-24.3-21.fc20

Comment 7 Fedora Update System 2014-08-06 05:10:49 UTC
emacs-24.3-22.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/emacs-24.3-22.fc20

Comment 8 Fedora Update System 2014-08-15 02:52:06 UTC
emacs-24.3-22.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.