Bug 1122164 - rfe - add text color to make private and public updates distinct in "Case Discussion" output
Summary: rfe - add text color to make private and public updates distinct in "Case Dis...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: redhat-support-tool
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Keith Robertson
QA Contact: Filip Holec
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 16:54 UTC by Marc Sauton
Modified: 2016-07-04 01:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 07:34:25 UTC


Attachments (Terms of Use)
redhat-support-tool rpm containing the patch (216.48 KB, application/x-rpm)
2014-11-13 04:23 UTC, Mark Huth
no flags Details
redhat-support-lib-python rpm that goes with the attached redhat-support-tool rpm (222.32 KB, application/x-rpm)
2014-11-13 04:27 UTC, Mark Huth
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1406 normal SHIPPED_LIVE redhat-support-tool and redhat-support-lib-python update 2015-07-20 18:07:04 UTC

Description Marc Sauton 2014-07-22 16:54:21 UTC
Description of problem:

I do not know what it takes, but I would like to get a visual difference of the comment/update text depending on the private/public status when browsing the "Case Discussion" of the getcase menu.
May be in a distinctive pale color.
Then an option when creating a new comment for private/public would be needed, in the same way as adding an attachment.
Thanks for this great tool.
M.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Mark Huth 2014-11-13 03:30:23 UTC
Ok, so I've also added the ability to make private comments.

First though, and you are probably already aware of this, you need to add 'ponies = True' to your redhat-support-tool.conf (I didn't come up with this, but I don't want to change the functionality since its already in the code).

So once you've added that line, then you will be able to add private comments in interactive mode.  Note, you will be able to add private comments by passing '-p false' as an argument to addcomment (or addattachment).

$ redhat-support-tool 
Welcome to the Red Hat Support Tool.
Command (? for help): help addcomment

Usage: addcomment -c CASENUMBER <comment text here>
...
  -p PUBLIC, --public=PUBLIC
                        True or False.  Use this to toggle a public or private
                        comment (default=True).  Example: -p false
 
Eg:
$ redhat-support-tool addcomment -c 01194529 -p false 'this is a private comment from non-interactive mode'

$ redhat-support-tool 
Welcome to the Red Hat Support Tool.
Command (? for help): addcomment
Please provide a case number(or 'q' to exit): 01194529
Type your comment. Ctrl-d on an empty line to submit:
this will be a private comment from interactive mode
Is this a public comment ([y]/n)? n

I will attach rpms for you test out this functionality to see if its what you were looking for.

Comment 5 Mark Huth 2014-11-13 04:23:59 UTC
Created attachment 956931 [details]
redhat-support-tool rpm containing the patch

Comment 6 Mark Huth 2014-11-13 04:27:49 UTC
Created attachment 956932 [details]
redhat-support-lib-python rpm that goes with the attached redhat-support-tool rpm

Install them both together with:
# rpm -Uvh /path/to/downloaded/redhat-support-tool-0.9.7-2.el6.noarch.rpm /path/to/downloaded/redhat-support-lib-python-0.9.7-0.el6.noarch.rpm 

You can either use the -p false option with addcomment or addattachment to add a private comment/attachment, or you can add 'ponies = True' to ~/.redhat-support-tool/redhat-support-tool.conf and then you will be prompted after adding a comment/attachment if you want the comment/attachment to be public.

And also use getcase to test the case comment numbering and public/private flags on comments.

Let us know how you get on.

Comment 9 Mark Huth 2015-04-21 19:55:20 UTC
Hi Philip,

Please read through comment #3.  But basically you need to add 'ponies = True' into the redhat-support-tool.conf file before you can add private comments.  I might look to change this at some stage though.

-- Mark

Comment 13 errata-xmlrpc 2015-07-22 07:34:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1406.html


Note You need to log in before you can comment on or make changes to this bug.