Bug 1122169 - hammer import organization --upload-manifests-from expects user to transform spaces to underscores in manifest name
Summary: hammer import organization --upload-manifests-from expects user to transform ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Transitions
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Grant Gainey
QA Contact: Lukas Pramuk
URL:
Whiteboard:
Depends On:
Blocks: stargate-GA-tracker
TreeView+ depends on / blocked
 
Reported: 2014-07-22 17:11 UTC by Lukas Pramuk
Modified: 2014-09-11 12:22 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:22:39 UTC


Attachments (Terms of Use)

Description Lukas Pramuk 2014-07-22 17:11:15 UTC
Description of problem:
hammer import organization --upload-manifests-from expects user to transform spaces to underscores in manifest name. I would expect more verbose note on this in help/man page.

Version-Release number of selected component (if applicable):
rubygem-hammer_cli_import-0.8.0-1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. hammer import organization --help
...
    --upload-manifests-from MANIFEST_DIR Upload manifests found at MANIFEST_DIR/<org_name>.zip to matching organizations
...

Actual results:
no note

Expected results:
note about transforming spaces from org name to underscores in manifest names

Comment 1 RHEL Product and Program Management 2014-07-22 17:23:47 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Grant Gainey 2014-07-22 20:00:27 UTC
commit 66584b6f2406350d2933f281a50c2bbb83fb59eb

Comment 5 Lukas Pramuk 2014-08-25 16:16:59 UTC
VERIFIED. rubygem-hammer_cli_import-0.10.1-1.el6.noarch

# hammer import organization -h
Usage:
    hammer import organization [OPTIONS]

Options:
...
    --upload-manifests-from MANIFEST_DIR Upload manifests found at MANIFEST_DIR. Assumes manifest for "ORG NAME" will be of the form ORG_NAME.zip
...

Comment 6 Bryan Kearney 2014-09-11 12:22:39 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.