Bug 1122186 - Compilation fails if configured with --disable-xml-output option
Summary: Compilation fails if configured with --disable-xml-output option
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: mainline
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kaushal
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 17:47 UTC by santosh pradhan
Modified: 2015-05-14 17:42 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 17:26:26 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description santosh pradhan 2014-07-22 17:47:01 UTC
Description of problem:
./configure --disable-xml-output
make FAILs because of following change:

http://review.gluster.org/7663

i.e. cli/src/cli.h
int
cli_xml_snapshot_status_per_snap (xmlTextWriterPtr writer, xmlDocPtr doc,
                                  dict_t *dict, const char *keyprefix);

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. ./configure --disable-xml-output
2. make
3.

Actual results:

Making all in src
  CC       cli.o
In file included from cli.c:47:0:
cli.h:397:35: error: unknown type name ‘xmlTextWriterPtr’
cli.h:397:60: error: unknown type name ‘xmlDocPtr’
make[3]: *** [cli.o] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Expected results:
It should PASS.

Additional info:

Comment 1 Anand Avati 2014-07-23 09:58:35 UTC
REVIEW: http://review.gluster.org/8356 (cli: Fix build issue for --disable-xml-output) posted (#1) for review on master by Santosh Pradhan (spradhan@redhat.com)

Comment 2 Anand Avati 2014-07-23 10:01:56 UTC
REVIEW: http://review.gluster.org/8356 (cli: Fix build issue for --disable-xml-output) posted (#2) for review on master by Santosh Pradhan (spradhan@redhat.com)

Comment 3 Anand Avati 2014-07-23 12:56:12 UTC
REVIEW: http://review.gluster.org/8363 (cli: Fix no libxml compilation for snapshot status) posted (#1) for review on master by Kaushal M (kaushal@redhat.com)

Comment 4 Anand Avati 2014-07-24 10:04:44 UTC
COMMIT: http://review.gluster.org/8363 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit 6328019bd197efa25294194acaf946557d84f9fb
Author: Kaushal M <kaushal@redhat.com>
Date:   Wed Jul 23 18:08:08 2014 +0530

    cli: Fix no libxml compilation for snapshot status
    
    BUG: 1122186
    Change-Id: Ib887f2194258e85d40f65a758b6a963a17911395
    Signed-off-by: Kaushal M <kaushal@redhat.com>
    Reviewed-on: http://review.gluster.org/8363
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-by: Santosh Pradhan <spradhan@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 6 Niels de Vos 2015-05-14 17:26:26 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:35:29 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Niels de Vos 2015-05-14 17:37:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Niels de Vos 2015-05-14 17:42:42 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.