Bug 1122251 - Tree Mode view not updated properly when cluster configuration changes
Summary: Tree Mode view not updated properly when cluster configuration changes
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc
Version: rhgs-3.0
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
: ---
Assignee: Sahina Bose
QA Contact: RHS-C QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 19:09 UTC by Martin Bukatovic
Modified: 2018-01-30 11:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-30 11:40:20 UTC


Attachments (Terms of Use)
fig1 (51.18 KB, image/png)
2014-07-23 13:21 UTC, Martin Bukatovic
no flags Details
fig2 (57.32 KB, image/png)
2014-07-23 13:22 UTC, Martin Bukatovic
no flags Details
fig3 (55.84 KB, image/png)
2014-07-23 13:23 UTC, Martin Bukatovic
no flags Details
fig4 (78.22 KB, image/png)
2014-07-23 13:23 UTC, Martin Bukatovic
no flags Details

Description Martin Bukatovic 2014-07-22 19:09:57 UTC
Description of problem
======================

When cluster configuration is changed (eg. cluster rename),
the Tree Mode (the left part of console interface) is not updated.
Besides the inconviniece, it also prevents cluster nodes to be
shown in Results List.

To update tree view, one has to logout and login again.

Version-Release number of selected component (if applicable)
============================================================

~~~
# rpm -qa | grep -i rhsc                                                     
rhsc-webadmin-portal-3.0.0-0.12.el6rhs.noarch                                
rhsc-setup-plugin-ovirt-engine-common-3.0.0-0.12.el6rhs.noarch               
rhsc-branding-rhs-3.0.0-1.0.el6rhs.noarch                                    
rhsc-3.0.0-0.12.el6rhs.noarch                                                
rhsc-tools-3.0.0-0.12.el6rhs.noarch                                          
rhsc-dbscripts-3.0.0-0.12.el6rhs.noarch                                      
rhsc-doc-3.0.0-1.el6eng.noarch                                               
rhsc-monitoring-uiplugin-0.1.0-3.el6rhs.noarch                               
rhsc-lib-3.0.0-0.12.el6rhs.noarch                                            
rhsc-backend-3.0.0-0.12.el6rhs.noarch                                        
rhsc-sdk-python-3.0.0.0-0.2.el6rhs.noarch                                    
rhsc-setup-plugin-ovirt-engine-3.0.0-0.12.el6rhs.noarch                      
redhat-access-plugin-rhsc-3.0.0-1.el6rhs.noarch                              
rhsc-cli-3.0.0.0-0.2.el6rhs.noarch                                           
rhsc-setup-base-3.0.0-0.12.el6rhs.noarch                                     
rhsc-setup-plugins-3.0.0-0.2.el6rhs.noarch                                   
rhsc-setup-3.0.0-0.12.el6rhs.noarch                                          
rhsc-restapi-3.0.0-0.12.el6rhs.noarch                                        
rhsc-log-collector-3.0.0-4.0.el6rhs.noarch 
~~~

How reproducible
================

100%

Steps to Reproduce
==================

1. Install RHSC and login into the web interface
2. Rename 'Default' cluster into eg. "BrownFieldCluster"
3. Add first node into the cluster

Actual results
==============

The new node is now show neither in the Results list or the Tree Mode itself.

The node is not shown even in the Results list because the Search field
contains string based on the information from the Tree Mode view:

~~~
Host: cluster = Default
~~~

And since the cluster is named "BrownFieldCluster" now, the Results
list is empty.

Expected results
================

Tree Mode is updated so that new node is immediatelly visible in both Results
list and Tree Mode.

Additional info
===============

Similar problem happens when new node is added: the Tree Mode is not updated,
but this at least doesn't break anything additional like in the case of cluster
naname.

Comment 2 Martin Bukatovic 2014-07-23 13:21:55 UTC
Created attachment 920219 [details]
fig1

Comment 3 Martin Bukatovic 2014-07-23 13:22:43 UTC
Created attachment 920220 [details]
fig2

Comment 4 Martin Bukatovic 2014-07-23 13:23:09 UTC
Created attachment 920221 [details]
fig3

Comment 5 Martin Bukatovic 2014-07-23 13:23:33 UTC
Created attachment 920222 [details]
fig4

Comment 6 Martin Bukatovic 2014-07-23 13:24:28 UTC
To better ilustrate the problem, I'm attaching some screenshots:

 * At first (fig1) I have clean initial state with empty "Default" cluster.
 * I rename it (fig2) to "BrownFieldCluster".
 * I add few hosts into the cluster. But after I fill out the the "New host"
   window, the new host is not shown in the Results list (fig3)

When I logout and login again, it works as expected (fig4).

Comment 7 Martin Bukatovic 2014-07-24 11:29:08 UTC
It seems I have overlooked the refresh button for the Tree Mode pane. That said
I don't think it's reasonable to expect that new user will realize he needs to
click on it to get proper information in the Results list.

Comment 9 Sahina Bose 2018-01-30 11:40:20 UTC
Thank you for your bug report. However, this bug is being closed as it's on a component where no further new development is being undertaken.


Note You need to log in before you can comment on or make changes to this bug.