Bug 1122252 - tomcat requires systemd-sysv when it shouldn't need to
Summary: tomcat requires systemd-sysv when it shouldn't need to
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tomcat
Version: 7.0
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: David Knox
QA Contact: tomcat-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 19:11 UTC by John Fulton
Modified: 2018-12-06 17:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-09 18:20:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1104138 0 medium CLOSED certmonger requires systemd-sysv when it wouldn't need to 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1105045 1 None None None 2021-01-20 06:05:38 UTC

Description John Fulton 2014-07-22 19:11:49 UTC
Description of problem:

The tomcat package has

  Requires(post): systemd-sysv

even if it is probably not needed.

Version-Release number of selected component (if applicable):

  tomcat-7.0.42-4.el7.noarch

How reproducible:

Deterministic.

Steps to Reproduce:
1. Have RHEL 7 installation without systemd, for example in a Docker container with fakesystemd.
2. Run yum install -y tomcat.

Actual results:

Transaction check error:
  file /usr/lib/rpm/macros.d/macros.systemd from install of systemd-208-11.el7.x86_64 conflicts with file from package fakesystemd-1-14.el7.x86_64

Expected results:

The installation passes, tomcat does not force the systemd-sys (and thus systemd) installation.

Additional info:

The the following can be used as a workaround: 

   yum swap -y -- remove fakesystemd -- install systemd systemd-libs

but it increases the image size unnecessarily. 

Bugs 1104138 and 1105045 are similar.

Comment 2 Václav Pavlín 2014-08-20 12:21:26 UTC
I think the simplest solution is to let fakesystemd also provide "systemd-sysv" as proposed in BZ #1126409.

systemd-sysv-convert will obviously fail but that shouldn't affect the result of the package installation.

Feel free to prove me wrong,
Vaclav

*** This bug has been marked as a duplicate of bug 1126409 ***

Comment 3 Jan Pazdziora 2014-08-20 12:36:23 UTC
As noted in bug 1104138 comment 8, I don't think this is a duplicate. I'll leave it to the reporter of this bug though to reopen this bugzilla if they feel like the Requires should be removed.

Comment 4 John Fulton 2014-08-20 13:30:47 UTC
Why should tomcat depend on systemd?


Note You need to log in before you can comment on or make changes to this bug.