Bug 1122258 - [CISCO RHEL-OSP] Unrecognised command in the DOC
Summary: [CISCO RHEL-OSP] Unrecognised command in the DOC
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: doc-Installation_Guide
Version: 1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 1.0
Assignee: Don Domingo
QA Contact:
URL:
Whiteboard:
: 1122746 (view as bug list)
Depends On: 1122746
Blocks: 1174326 1198800
TreeView+ depends on / blocked
 
Reported: 2014-07-22 19:28 UTC by satya routray
Modified: 2016-04-29 16:17 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1122746 (view as bug list)
Environment:
Last Closed: 2015-10-09 03:46:08 UTC


Attachments (Terms of Use)

Description satya routray 2014-07-22 19:28:05 UTC
While following "https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/5/html/Getting_Started_Guide/chap-Product_Requirements.html#sect-Configure_Software_Repositories"

for RHEL OSP Packstack installation we saw some unsupported commands mentioned in the doc

<SNIP>
For example, to ensure that the repository for Red Hat Enterprise Linux OpenStack Platform 3 (Grizzly) has been disabled, run:
# subscription-manager --disable rhel-server-ost-6-3-rpms
Loaded plugins: product-id                                 
==== repo: rhel-server-ost-6-3-rpms ====
[rhel-server-ost-6-3-rpms]
bandwidth = 0
base_persistdir = /var/lib/yum/repos/x86_64/6Server
baseurl = https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/openstack/3/os
cache = 0
cachedir = /var/cache/yum/x86_64/6Server/rhel-server-ost-6-3-rpms
cost = 1000
enabled = False
...

</SNIP>

where as subscription-manager don't have any option "--disable"

Below is the list of commands which subscription-manager supports
<SNIP>
[root@cvf3-server-a1 ~]# subscription-manager --help
Usage: subscription-manager MODULE-NAME [MODULE-OPTIONS] [--help]

Primary Modules: 

  attach         Attach a specified subscription to the registered system
  list           List subscription and product information for this system
  refresh        Pull the latest subscription data from the server
  register       Register this system to the Customer Portal or another subscription management service
  release        Configure which operating system release to use
  remove         Remove all or specific subscriptions from this system
  status         Show status information for this system's subscriptions and products
  unregister     Unregister this system from the Customer Portal or another subscription management service

Other Modules:   

  auto-attach    Set if subscriptions are attached on a schedule (default of daily)
  clean          Remove all local system and subscription data without affecting the server
  config         List, set, or remove the configuration parameters in use by this system
  environments   Display the environments available for a user
  facts          View or update the detected system information
  identity       Display the identity certificate for this system or request a new one
  import         Import certificates which were provided outside of the tool
  orgs           Display the organizations against which a user can register a system
  plugins        View and configure subscription-manager plugins
  redeem         Attempt to redeem a subscription for a preconfigured system
  repo-override  Manage custom content repository settings
  repos          List the repositories which this system is entitled to use
  service-level  Manage service levels for this system
  subscribe      Deprecated, see attach
  unsubscribe    Deprecated, see remove
  version        Print version information
</SNIP>

Comment 2 Don Domingo 2015-01-16 00:14:07 UTC
Hi Satya, I apologize for the delay in fixing this. I've since corrected the bug and it should be fixed in the upcoming release (RHELOSP-6). In addition, we'll be updating the RHELOSP-5 version soon as well.

Anyhow, the correct command should be:

# subscription-manager repos --disable rhel-server-ost-6-3-rpms

Comment 3 Andrew Dahms 2015-01-16 01:07:26 UTC
*** Bug 1122746 has been marked as a duplicate of this bug. ***

Comment 5 Andrew Dahms 2015-10-09 03:46:08 UTC
These changes are now live on the Customer Portal.

Closing.


Note You need to log in before you can comment on or make changes to this bug.