Bug 1122277 - [Feature] Backup and Restore API for Independent Software Vendors (ISV)
Summary: [Feature] Backup and Restore API for Independent Software Vendors (ISV)
Keywords:
Status: CLOSED DUPLICATE of bug 1108245
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: rhev-docs@redhat.com
QA Contact: ecs-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 20:21 UTC by Zac Dover
Modified: 2014-12-08 06:09 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-08 06:09:32 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Zac Dover 2014-07-22 20:21:09 UTC
This is a complicated feature which will require significant expertise in order to document properly. 

Here is the oVirt Features Page for this feature:
http://www.ovirt.org/Features/Backup-Restore_API_Integration

What little official there is on this putative feature is found in the RHEV 3.4 Technical Guide,here:

https://documentation-devel.engineering.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.4/html-single/Technical_Guide/index.html#Red_Hat_Enterprise_Virtualization_Windows_Guest_VSS_Support

NVR of Guide Linked Above
-------------------------
Red_Hat_Enterprise_Virtualization-Technical_Guide-3.4-en-US-3.4-18.001


Remarks
-------
There is precious little information about the Backup and Restore API for Independent Software Vendors even in the email record.

The oVirt 3.3 release management page lists the feature as red, which indicates to me that this was never thorougly implemented.
http://www.ovirt.org/OVirt_3.3_release-management

Caveat scriptor. Infelix scriptor, dii vertant bene quod agas.

Finally, if this feature has in fact not been developed by two-thirds of the way through the development cycle, close this bug NOTABUG.

Comment 1 Zac Dover 2014-07-22 20:22:34 UTC
This bug descends from https://bugzilla.redhat.com/show_bug.cgi?id=975685

Comment 2 Zac Dover 2014-07-22 20:23:41 UTC
Re: Description, above:

s/what little official there is/what little official documentation there is/g

Comment 3 Julie 2014-12-08 06:09:32 UTC

*** This bug has been marked as a duplicate of bug 1108245 ***


Note You need to log in before you can comment on or make changes to this bug.